Doubles of songs in itunes?

Discussion in 'Mac Apps and Mac App Store' started by JHNguyen, Feb 3, 2008.

  1. JHNguyen macrumors member

    Apr 14, 2006
    For some reason, when I add songs in my itunes library.. there are doubles of songs..

    I have a pretty large library of music, and their may be doubles of songs, but 80% are not.. just when they are sent to itunes, they get doubled somehow.

    Is their a way to delete these, or prevent it from happening?
  2. forafireescape macrumors 6502a


    Jan 16, 2008
    Go to the view menu, and click "show duplicates." From there you can choose what to do. Hope that helps!
  3. McGiord, Feb 3, 2008
    Last edited: Jan 30, 2011

    McGiord macrumors 601


    Oct 5, 2003
    Dark Castle
    Activate the setting to keep your iTunes Library organized, so it will create folders inside your Music Library by Artists and their Albums. Also you can disable the option to copy the music to your iTunes Library so you keep the song files in other places if you want.
    vaporizer reviews
  4. Melrose Suspended


    Dec 12, 2007
    I have the same problem - mine is a bit more problematic because there are some songs that I like having multiples of (Live cut, album cut, acoustic cut, etc), and for some reason iTunes disables the "Show Duplicates" button except or what's on my iPod (???).

    What I do is sort by song title and then scroll through all my music exhaustively looking for duplicate versions I don't want.
  5. taeclee99 macrumors 6502a


    Jun 4, 2002
    Anywhere but here
    I assume you are adding these songs into iTunes from a folder and not from a cd. If you are importing these songs into iTunes from a folder, make sure there is no playlist file (.m3u) in that folder. Having this file in the folder will cause iTunes to create duplicates while importing. iTunes will not create duplicates when importing straight from cd.

    Hope this helps.

Share This Page