Downgrade 4.3.5 to 4.2.1 then upgrade to 4.3.3?

Discussion in 'Jailbreaks and iOS Hacks' started by bmw000, Aug 28, 2011.

  1. bmw000 macrumors member

    Joined:
    Sep 1, 2008
    #1
    I have a question that I cannot find an answer to.

    I am currently on 4.3.5.

    I have my 4.2.1 SHSH's saved, but that's it. I never saved my 4.3.3 SHSH's.

    I can downgrade back to 4.2.1 since the SHSH's are saved.

    Once I am downgraded to 4.2.1 can I simply update to 4.3.3?

    Or is it only possible to update to the current version? Does Apple check SHSH on an upgrade like to they do on a downgrade?

    Thanks,
    bmw000
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2
    You can only downgrade back to 4.2.1 since you have the SHSH saved. Apple stops signing the previous firmware when a new software version comes out.

    So going from 4.2.1 to 4.3.3 can't happen unless the SHSH is saved for 4.3.3
     
  3. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
  4. P!kN!mO macrumors member

    P!kN!mO

    Joined:
    Aug 14, 2011
    #4
    try looking for a "Custom firmware 4.3.3" ,..made from Sn0wbreeze or PwnageTool(restore to iTunes)...i haven't tried it yet but maybe it will work and it will preserve your baseband!..... worth trying!!!
     
  5. budgynana macrumors member

    Joined:
    Nov 28, 2010
    #5
    nope, won't work.
     
  6. awadeee macrumors 68020

    awadeee

    Joined:
    Jan 21, 2011
    Location:
    Viper City
    #6
    If you don't have SHSH blobs for 4.3.3 you can't restore to it.
     
  7. bmw000 thread starter macrumors member

    Joined:
    Sep 1, 2008
    #7
    I was afraid of that.

    Thanks for helping me out.

    bmw000
     
  8. P!kN!mO, Aug 29, 2011
    Last edited: Aug 29, 2011

    P!kN!mO macrumors member

    P!kN!mO

    Joined:
    Aug 14, 2011
    #8
    just tried it on my friend's iPhone:eek:....you were right!(silly me):D
    i told him it wont work as the thread said...but he was persistent to try!

    Good thing i save mine...
     
  9. oplix Suspended

    oplix

    Joined:
    Jun 29, 2008
    Location:
    New York, NY
    #9
    if you have 4.2.1 blobs saved you might as well go back to that. 4.2.1 performs better in almost everything compared to 4.3.3
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    That will NOT work.
    You need shsh blobs for official or custom firmware installs.
    So no blobs for that version then you can never install it.
     
  11. Invincibilizer macrumors 6502a

    Invincibilizer

    Joined:
    Aug 18, 2011
    #11
    So would it be advised to save SHSH blobs for every incremental firmware update


    4.0
    4.1
    4.2
    4.2.1
    4.3.3

    So that in the event a user has to downgrade they have a wide variety of SHSH blobs to work with?

    Any response would be appreciated :D
     
  12. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #12
    Yes. Right now, you can save the blob for 4.3.5, because that's the current release. Due to issues with cydia, one should also manually save in tiny umbrella.
    However, once iOS 5 comes out, we're going to have changes, because the blobs won't work with the new iOS.
     
  13. bigred7078 macrumors 6502a

    bigred7078

    Joined:
    May 6, 2010
    Location:
    North Carolina
    #13
    I'm still on 4.2.1, is it possible to get 4.3.3 if I never upgraded to it? or am I out of luck?

    ----------


    nevermind, looks like someone further up already answered you cannot do this.
     
  14. bigred7078 macrumors 6502a

    bigred7078

    Joined:
    May 6, 2010
    Location:
    North Carolina
  15. Invincibilizer macrumors 6502a

    Invincibilizer

    Joined:
    Aug 18, 2011
    #15
    Just to clarify

    -So when iOS 5 comes out, I should use tiny umbrella and save EVERY iOS 5 update in the event I need it? :)
     
  16. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #16
    When iOS5 comes out most likelly TU will be useless on saving blobs on anything 5.0 and higher.
    Apple is implementing better blob checks that cannot be saved and replayed.
     
  17. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #17
    try this i had a similar problem and it worked for me

    i was on 4.1 for ever then when 4.3.3 was still being signed i updated

    cydia saved 4.2.1 for me so when i saved my 4.3.3 blobs, cydia downloaded 4.2.1 to my computer so than i was able to restore to 4.2.1 even though i never had 4.2.1 while it was being signed

    i know the numbers are not the same in your situatution but since you had blobs for 4.2.1 maybe cydia saved 4.3.3 for you

    so save the 4.3.5 blobs and see if 4.3.3 appears in your saved blob list
     
  18. rmarconcini macrumors newbie

    Joined:
    Dec 19, 2011
    #18
    Hi! I need your help..

    iPhone 4 bb 4.10 working perfect with gevey. Im on ios 4.3.5 and i have shsh saved for 4.2.1. Can i downgrade to 4.2.1 and keep the bb 4.10 for an unterthered jailbreak and unlock with gevey sim ?
    Is safe to downgrade to ios 4.2.1 without problems ?



    Thks for your help ;)


    Br;
    rmarconcini
     
  19. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #19
    Yes, as long as you got blobs you can downgrade to 4.2.1 with no probs.
    And your gevey unlock will work fine.
     
  20. rmarconcini macrumors newbie

    Joined:
    Dec 19, 2011
    #20
    Mate thks for reply.
    One more question. What 4.2.1 firmware i must choose, original or custom for keep 4.10 baseband ?



    BR;
    rmarconcini
     
  21. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #21
    Up to you. It won't make any difference in this occasion.
    You can go stock and jb after or straight to jb ipsw.
     

Share This Page