Downgrade iOS 5 Beta 7 to 4.3.3

Discussion in 'Jailbreaks and iOS Hacks' started by hypervish89, Sep 16, 2011.

  1. hypervish89, Sep 16, 2011
    Last edited: Sep 16, 2011

    hypervish89 macrumors regular

    Joined:
    Apr 6, 2010
    #1
    I'm trying to downgrade iOS 5 beta 7 to 4.3.3.
    I have shsh blobs. i tried downgrading and got error 1015 which means the ipsw installed but iTunes won't let me get out of recovery mode...I tried fix recovery (the standalone program), tiny umbrella fix recovery, ireb,recboot and redsnow. But none of them got me out of recovery mode, am I missing something? I tried recovering in regular dfu mode, pwnded dfu mode, and normal, but all gave the same error. Currently, I'm back on iOS 5 but I'd like to downgrade asap. I can't downgrade to anything, 4.3.3, or 4.3.5. I have shsh blobs for all of them though.

    BTW: I am a dev, I have iOS 5 on my iPhone 4 which i use for developing apps along with my team. I upgraded my iPhone 3gs which is my dd, but I soon realized that it would be better to have 4.3.3 so that I can make sure my apps function on 4.3.3 as well without any crashes...LOL
     
  2. Kayan macrumors 6502

    Joined:
    Jul 7, 2010
    Location:
    CA
    #2
    I'm not an expert at this, but one of the Apple Geniuses told me that it's impossible to downgrade from iOS5 once you've installed it. Even if you have your .shsh files...he said that they are actually having a difficult time with that because dev's will bring in their iPhones to the store to get it fixed somehow, but not even the applestore can downgrade their phone.
     
  3. seanwebb68 macrumors 6502

    Joined:
    Jul 27, 2010
    #3
    Well i managed to downgrade back to 4.3.3 by restoring as normal then when it finished and was stuck on recovery mode, i put in in DFU mode and jailbroke it and it worked fine and booted as normal after that
     
  4. hypervish89 thread starter macrumors regular

    Joined:
    Apr 6, 2010
    #4
    I was able to downgrade when I had beta 5. After that, I never tried.

    So, I think apple changed something after beta 5 that prevents downgrading.
     
  5. Djlild7hina macrumors 6502a

    Joined:
    Mar 28, 2009
    #5
    it's still possible but make sure your host file points to apple servers instead of pointing to cydia server and put it in dfu mode and restore.
    Edit: sorry think the latest i installed was beta 6.. ignore my post haha
     
  6. hypervish89 thread starter macrumors regular

    Joined:
    Apr 6, 2010
    #6
    I can get it to successfully restore but i then get error 1015. Which means it's stuck in recovery mode. When I try jail breaking or using fix recovery, it tells me the NAND initialization failed and I need to reformat with "______" enabled... I don't remember what the blank was, I'm back on beta 7 for now. Till I can figure out how to successfully restore.
     
  7. Azadre macrumors 6502

    Joined:
    Jun 27, 2005
    Location:
    USA
    #7
    In the same boat as the OP. I guess I'll just be on iOS 5 beta until GM.
     
  8. TMar macrumors 68000

    TMar

    Joined:
    Jul 20, 2008
    Location:
    Ky
    #8
    Completely incorrect. I've downgraded from iOS5 3 times.
     
  9. jredecop macrumors 6502a

    Joined:
    May 20, 2009
    #9
    Try downgrading to 4.3.5 from dfu first then to 4.3.3. Thats hat i had to do to get it work.
     
  10. hypervish89 thread starter macrumors regular

    Joined:
    Apr 6, 2010
    #10
    I just tried downgrading to 4.3.5 but same problem. 1015. I tried recboot exit recovery, tiny umbrella fix recovery, standalone fix recovery program and I tried redsnow 0.9b1 (it has a new feature to exit recovery mode). None of them worked... :confused: lol
     
  11. jredecop macrumors 6502a

    Joined:
    May 20, 2009
    #11
    From dfu?
     
  12. hypervish89 thread starter macrumors regular

    Joined:
    Apr 6, 2010
  13. EllieV macrumors 6502

    Joined:
    Apr 22, 2010
    #13
    I have been able to downgrade from iOS 5 beta 7 to iOS 4.3.5
    But i cannot downgrade from 4.3.5 to 4.3.3
    any suggestions? it may be because i don't have shsh blobs? how do i fix that?
     
  14. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #14
    no blobs no 4.3.3 ;)
     
  15. hypervish89 thread starter macrumors regular

    Joined:
    Apr 6, 2010
    #15
    ^what he said. if you don't have the blobs, you can't do it. You can try editing the hosts file, but that may or may not work.
     

Share This Page