Downgrade iPhone 4 7.1.2 to IOS 5 Possible?

rsg1010

macrumors member
Original poster
Jan 8, 2014
67
18
I currently have a iPhone 4 jailbroken on IOS 5.1.1 and was wanting to update the phone to IOS 7.1.2 and then jailbreak again. My question is if I would like to downgrade back to IOS 5.1.1...is that possible?

If so, would someone mind telling me the steps needed. Thanks
 

redheeler

macrumors 604
Oct 17, 2014
7,403
6,969
I don't think it's possible to downgrade to a version no longer being signed by Apple. You'd be stuck on 7.1.2.
 

bbrks

macrumors 65816
Dec 17, 2013
1,446
768
I currently have a iPhone 4 jailbroken on IOS 5.1.1 and was wanting to update the phone to IOS 7.1.2 and then jailbreak again. My question is if I would like to downgrade back to IOS 5.1.1...is that possible?

If so, would someone mind telling me the steps needed. Thanks
Yes you can, if you have SHSH blobs saved for 5.1.1.
Actually, I heard it's also possible even without SHSH blobs, but I never tried it, so I suggest GOOGLE search :)
 
Last edited:

eyoungren

macrumors Core
Aug 31, 2011
21,180
13,021
ten-zero-eleven-zero-zero by zero-two
I don't think it's possible to downgrade to a version no longer being signed by Apple. You'd be stuck on 7.1.2.
The iPhone 4 can still be downgraded because of a boot rom exploit that was not patched until the 4s. The 4s and the 5 can take advantage of Odyessus but you may be limited to which version you can go to based on if you have blobs or not.
 

Rekan_

macrumors member
Jun 11, 2015
69
36
London, UK
I currently have a iPhone 4 jailbroken on IOS 5.1.1 and was wanting to update the phone to IOS 7.1.2 and then jailbreak again. My question is if I would like to downgrade back to IOS 5.1.1...is that possible?

If so, would someone mind telling me the steps needed. Thanks
Use iFaith on windows, it is the only tool you can use to backup your SHSH on 5.1.1, keep that then upgrade to 7.1.2, if you downgrade to 5.1.1 again, use iFaith to create a custom IPSW with the SHSH blobs of 5.1.1 so you can downgrade.
 
  • Like
Reactions: Applejuiced

oink22

macrumors newbie
Apr 29, 2016
14
0
You should try tinyumbrella first:).
Because you might have more shsh blobs for example 4.3.3.

P.S I did downgraded my iPhone 4 to 5.1.1 using redsn0w:)
 

rsg1010

macrumors member
Original poster
Jan 8, 2014
67
18
Hi Everyone,

Just a quick update...I was able to use iFaith on windows and fetch my blobs from cydia (5.1.1 and 6.1.3). I was able to upgrade to 7.1.2 and also downgrade back to 5.1.1 with my blobs.

Amazing how quick 5.1.1 is with a few cydia tweaks compared to 7.1.2. Anyways thanks everyone for the help.
 
  • Like
Reactions: Applejuiced