downgrade Ipod touch 2g from 4.0 to 2.2.1

Discussion in 'iPod touch Hacks' started by dr3asal, Jul 25, 2010.

  1. dr3asal macrumors newbie

    Joined:
    Jul 25, 2010
    #1
    Hi there every1 ..
    i have and i pod touch 2g 32gb on 4.0 neverbeen jailbroken and i need to downgrade it to 2.2.1 and im a mac user can anyone please help me with that ..

    Thanks in Advance ..
     
  2. markojug macrumors regular

    Joined:
    Mar 16, 2009
    Location:
    In A House, Ontario, Canada
    #2
    Wirelessly posted (Mozilla/5.0 (iPod; U; CPU iPhone OS 4_0 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8A293 Safari/6531.22.7)

    I don't think you can downgrade to 2.2.1 anymore, just restore your iPod to 3.1.2 and you should be fine.

    Plus, what's there to hate about 4.0?
     
  3. dr3asal thread starter macrumors newbie

    Joined:
    Jul 25, 2010
  4. Kafluke macrumors member

    Joined:
    Jun 20, 2010
    #4
    Is your ipod touch an MC model? If the ipod has never been on 3.1.2 then you most likely will not be able to downgrade. There is a step in the process where itunes goes out to apple's servers to authenticate the firmware. You have to redirect itunes to look at a different server to downgrade. That server is run by Cydia. Here are the conditions that have to be in place to downgrade.

    Back when apple was signing 3.1.2 firmware (or anything lower than 4.0) you would have had to JB your ipod and then saved your shsh blobs using the application Cydia (by clicking on "make my life easier") or you could have used TinyUmbrella to do the same thing or even save them on your computer locally.

    If you didn't do any of these things then when you go to downgrade your firmware itunes will first look to apple to sign them. Apple is currently only signing 4.0.1 firmware so this will error out. Next everyone on this forum will tell you to point itunes to Cydia's server instead of Apple's. Like I said though if you didn't save your shsh blobs back in the day then when you go to downgrade and itunes looks on Cydia's sever for authentication it will also error out (most likely with a 3194 error).
     
  5. Macloven macrumors regular

    Macloven

    Joined:
    Aug 25, 2008
    #5
    If it's an MB model (check the about screen) it might work. I'm currently restoring my 2g 32mb MB back down to 2.2.1. I found 2.2.1 on the felixbrun site, put the touch in DFU mode, pointed to the 2.2.1 file using the option click trick and so far, so good.

    http://www.felixbruns.de/iPod/firmware/

    I have received some error messages during the restore process, but they're all related to incompatibility between some of my apps that were upgraded to 4.0 versions. Those weren't restored and hoping everything else works.

    The restore just completed, and everything seems fine. A few apps won't work and guessing they are too new for 2.2.1, but I really just want my music to work again properly in my car. Overall the unit seems much snappier, just like the old days....
     
  6. dr3asal thread starter macrumors newbie

    Joined:
    Jul 25, 2010
    #6
    my ipod has never been jailbroken any1 plz i need help urgently
     
  7. Macloven macrumors regular

    Macloven

    Joined:
    Aug 25, 2008
    #7
    as noted in my post above, I was able to get it work. Be more specific what you need help with and where it's failing and we might be able to help you.

    mg
     
  8. Kafluke macrumors member

    Joined:
    Jun 20, 2010
    #8
    Seriously dude, did you even read the replies above?
     
  9. dr3asal thread starter macrumors newbie

    Joined:
    Jul 25, 2010
    #9

    my ipod is an MB model and the problem occurs after doing the option+restore and picking the 2.2.1 firmware the i tunes says extracting ... then preparing ur i phone for restore and my ipod screen turns white then apple logo appears on it then the itunes usb cable appears again and i tunes gives me the error code 20 msg ....

    so plz tell me which i-tunes version did u use and did u do anything else inorder for the restore to work with u ..

    thanx in advance ..
     
  10. dr3asal thread starter macrumors newbie

    Joined:
    Jul 25, 2010
    #10
    i was able to downgrade my ipod touch 2g from 4.0 to the 3.0 firmware can i go to 3.1.2 or 2.2.1 from here .. anybody plz urgent help needed ..
     
  11. flipdroid macrumors newbie

    Joined:
    Aug 4, 2010
    #11
    I just joined this forum to help people with the ipod touch 2g downgrade issue, and the steps to get to where my itouch is now...

    I have the MC model and the closest to 3.1.3 i could get is 3.0, but it takes care of the ****** 4.0 update that ****ed up my itouch.

    i downloaded itunes 8.2 and restored back to 2.1, then downloaded itunes 9.0 and restored to 3.0, and no version of itunes that i tried will take you back up to 3.1.2 or 3.1.3.

    I only invested so much time to get where it is now because i use it to stream pandora and slacker at work and i couldn't get more than 4 songs on slacker and 10 songs on pandora before it crashed miserably.

    if you want something that is more fun to hack and thoroughly enjoy get a Droid, the community is far more fun to interact with and the possibilities of customization FAR exceeds anything Apple will ever produce
     
  12. jmgravenor macrumors newbie

    Joined:
    Aug 15, 2010
    #12
    hay dude i also have the same problem. but except im using itunes 9.2 and i want to downgrade to 3.1.2 but it says that the device isnt elegible for the requested build!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1:(
     

Share This Page