Apple TV Downgrading and Jailbreaking apple tv 2g woes

Discussion in 'Jailbreaks and iOS Hacks' started by justinmiller, Apr 3, 2011.

  1. justinmiller macrumors newbie

    Joined:
    Jul 1, 2010
    #1
    Do I got my brand new, shiny, apple tv 2g yesterday. I downloaded greenpoison and it said to upgrade to iOS 4.2.1 before upgrading. Now, this was before I understood the discrepancy between Apple TV software versions and iOS versions. I thought they were one and the same. SO I updated, attempted the jailbreak and it failed, predictably.

    I then searched around and found download links for previous firmware. I found this link: http://www.iclarified.com/entry/index.php?enid=970

    And started downloading firmwares starting with 4.1. They didn't work because they didn't pass verification (because I didn't previously save off my shsh blobs). I then downloaded and tried the firmware 4.2.1 from that page and that worked. It successfully restored. I booted up Apple TV and checked the software version and now it was back to 4.1.1 -- where it started when i first bought it.

    I then tried to jailbreak using greenpoison and it failed again. I got it into DFU mode but it just said jailbreak failed. Anyone know why??

    Also, I was surprised I was even able to downgrade. Any thoughts here?

    Thanks!

    Justin
     
  2. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Cal
    #2
    When you're checking the firmware version, press the center button and it give u more readings.
     
  3. justinmiller thread starter macrumors newbie

    Joined:
    Jul 1, 2010
    #3
    So what iOS and Apple TV version combo can be jailbrokeb with Greenpoison, at the moment?

    I'm not at home at the moment so I can get more info as described above, but I know it says 4.1.1 on that main screen. And that was after restoring with the 4.2.1 firmware as described above. Is it possible for the Apple TV firmware version to read 4.1.1 while the iOS version is 4.3?

    Since it appears like I was able to downgrade, why wouldn't greenpoison be working? After entering DFU mode, it appears to attempt the jailbreak, but then the jailbreak button reads "Failed :(".
     
  4. jgunn macrumors regular

    Joined:
    Apr 7, 2008
    #4
    it sounds like you have downgraded successfully and you're just having trouble jailbreaking. try seas0pass instead of green poison.
     
  5. justinmiller thread starter macrumors newbie

    Joined:
    Jul 1, 2010
    #5
    Ok, so I'm an idiot.

    Yes, downgrade worked. Following advice from the greenpoison README, I tried running GP via the terminal using sudo, which i couldn't do because I wasnt an admin on my wife's computer (or more specifically I wasn't in the sudoers file). Once I remedied that, I reran greenpoison and it proceeded perfectly. I had forgotten that you need to be root in order to jailbreak.

    Now i have a wonderfully jail broken apple tv running xbmc!
     
  6. freakmonger macrumors newbie

    Joined:
    Apr 3, 2011
    #6
    How is XBMC on ATV2? Is the quality good or do the movies lag?
     
  7. justinmiller thread starter macrumors newbie

    Joined:
    Jul 1, 2010
    #7
    I think it's great! Then again, I'm only streaming standard def DVD rips, no blueray. But so far, no lags. Quality has been as good as Boxee running on my MBP. I haven't had much more time to play with xbmc yet, but as I said, I'm very satisfied.
     

Share This Page