Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Downgrading first generation iphone

iKrl

macrumors regular
Original poster
Jun 2, 2009
248
12
I was looking at the story of the iPhone OS and thought to myself that it would be cool to compare the current 3.1.3 on the 3GS with the first generation iPhone (bought it on March 2008 so firmware was like 1.1.3). What I wanted to do was to downgrade my iPhone 1st gen to 1.0 but already tried restoring it to that firmware with no luck. It is now on the 3.1.3 and I don't know how to downgrade it all the way to the first version of the iPhone OS.
Does anyone have any ideas?
 

Intell

macrumors P6
Jan 24, 2010
18,902
420
Inside
You would have to first find the firmware file, then put your iPhone into DFU mode, then while holding down shift on Windows or option on Mac, click the restore button for your iPhone, and select the 1.0 firmware.
 
Comment

iKrl

macrumors regular
Original poster
Jun 2, 2009
248
12
You would have to first find the firmware file, then put your iPhone into DFU mode, then while holding down shift on Windows or option on Mac, click the restore button for your iPhone, and select the 1.0 firmware.

I tried that and when I click on the 1.0 firmware it says "extracting software" and suddenly it says it couldn't do it with (20) as the error.
Do you think it has to do with when I bought the iPhone? Like I said it was late march 2008 and the box had the iTunes icon on it already.
 
Comment

sysiphus

macrumors 6502a
May 7, 2006
816
1
I tried that and when I click on the 1.0 firmware it says "extracting software" and suddenly it says it couldn't do it with (20) as the error.
Do you think it has to do with when I bought the iPhone? Like I said it was late march 2008 and the box had the iTunes icon on it already.

The issue is that the baseband was also flashed, and you can't install a firmware older than the corresponding baseband (easily/effectively).
 
Comment

Intell

macrumors P6
Jan 24, 2010
18,902
420
Inside
This is just a guess but did you try an older version of iTunes? And are you sure that you're in DFU mode?

The issue is that the baseband was also flashed, and you can't install a firmware older than the corresponding baseband (easily/effectively).

Can't you downgrade the iPhone Gen 1's baseband with BootNuter if you have the needed files by using PwnageTool?

Edit: I would now suggest try using PwnageTool to create a custom firmware with 2.x and flashing the baseband back to the 3.9 version. Then try downgrading back to 1.0.
 
Comment

iKrl

macrumors regular
Original poster
Jun 2, 2009
248
12
This is just a guess but did you try an older version of iTunes? And are you sure that you're in DFU mode?



Can't you downgrade the iPhone Gen 1's baseband with BootNuter if you have the needed files by using PwnageTool?

Edit: I would now suggest try using PwnageTool to create a custom firmware with 2.x and flashing the baseband back to the 3.9 version. Then try downgrading back to 1.0.

Just to clarify, do I need to hack the iPhone to a much older version, say 1.1.4 or something and download these things to downgrade to an older baseband which would then let me downgrade to version 1.0?

O and by the way I tried using iTunes version 7.3.2 (oldest I could get which would work with the iPhone) and nothing happened, well actually the same thing happened, it said it couldn't do it because of (-50) the first time, then it was because of (20).
 
Comment

iKrl

macrumors regular
Original poster
Jun 2, 2009
248
12
I doubt it will work.
The baseband and firmare won't match and will not let you restore to 3 year old firmware.

can't you just downgrade the baseband as well? it is a first gen iphone so I don't see why it can't work with something it worked with a long time ago
 
Comment

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,532
At the iPhone hacks section.
can't you just downgrade the baseband as well? it is a first gen iphone so I don't see why it can't work with something it worked with a long time ago

Not sure if you can downgrade it and with what tool.
Bootneuter flashes it and unlocks it but doesnt downgrade it to the old 1.0+ days.
I dont know if its worth your time and trouble to get this done. You will have to jump thru many many hoops and still it prob wont work.
 
Comment

rickstermar555

macrumors newbie
Jun 6, 2011
3
0
Hello Everyone,

I 'm using an original 8GB IPhone (1st generation) as an Ipod Touch. I figured why not try to update it to the new OS.
Now I'm stuck with the "Connect to Itunes" logo. It won't go to the HOME screen. I am able to make an emergency call. My PC won't detect the phone either.

I tried calling Apple Support, but they would charge me $29.99 just to talk to them.

How do I restore my old Iphone to the previous OS if I can't go to the HOME screen?

What is the latest OS that I would need to download to be compatible with my 1st generation phone? WIll I need to download an older version of Itunes as well?

What kind of 3rd party software is needed as well if I need it?

Thank you.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.