Downgrading from 5.0.1 to 4.2.1

Discussion in 'Jailbreaks and iOS Hacks' started by vong, Jan 4, 2012.

  1. vong macrumors 6502a

    vong

    Joined:
    Jan 31, 2010
    #1
    Is it still possible to downgrade from 5.0.1 to 4.2.1? Cydia has my blobs saved. I think all I had to do was put my phone into pwned dfu mode, use the custom ISPW for 4.2.1 to keep my baseband (1.59.00) and then do I have to edit my host file?
     
  2. Ali. macrumors member

    Joined:
    Jul 2, 2011
    Location:
    New Zealand
    #2
    Afaik, you shouldn't have any problem downgrading back. Out of curiosity, may I ask why?

    The reason I ask is because my iP4 is still sitting on 4.2.1 and I'm still trying to decide whether it's worth jumping over to iOS 5 and deal with the increased battery drain, losing jb tweak compatibility and having to port my themes etc over.
     
  3. Doba macrumors newbie

    Joined:
    Jan 4, 2012
    #3
    Using TinyUmbrella go to the advance tab in the middle of the screen. Check the request SHSH from Cydia. Make sure blobs are saved in TinyUmbrella before you start your restore.
     
  4. vong thread starter macrumors 6502a

    vong

    Joined:
    Jan 31, 2010
    #4
    Simply because my iPhone has the "signal issue" where it only displays "1" bar. I personally find that annoying. The only way to fix it is to install ultrasn0w, but IF you install ultrasn0w you will not receive visual voicemail & MMS. To fix that problem.. you would need to take out your simcard and put it back in every time you reboot your phone. As far as I know.. I think it is because of my baseband.

    Also the fact that iOS 5 does not have good looking Lockscreen themes yet.


    [​IMG]

    Am I good to go?
     
  5. Sensamic, Jan 4, 2012
    Last edited: Jan 4, 2012

    Sensamic macrumors 68030

    Joined:
    Mar 26, 2010
    #5
    Im trying to downgrade from iOS 5.0.1 to 4.3.3 just to try it out. I need to know how to do downgrades. Im having issues.

    I downloaded all my SHSH blobs from Cydia: 4.3.3, 4.3.4 and 4.3. I downloaded 4.3.3 firmware for my iPhone 4 and have all ready. Ive tried several times but no luck.

    My steps are opening tiny umbrella, set host to cydia on exit, start TSS server and then restoring. In the end I get an error and can get pass it. iTunes tells me again the iPhone is in recovery mode. I tried exit recovery and fix recovery with no luck.

    Ive edited my hosts file and all other stuff and still no luck. Any advice?

    EDIT: Solved. I made my own custom firmware with 4.3.3 and it worked.
     
  6. Ksizzle9, Jan 4, 2012
    Last edited: Jan 4, 2012

    Ksizzle9 macrumors 6502a

    Joined:
    Apr 15, 2011
    #6
    it seems we have had problems in the past so i apologize publicly for starters. But what errors are you getting when trying to restore? I ask because you could probably download iReb i think that will put it into a pwned DFU mode that will keep it from getting those errors. Give that a try, i could be wrong as i haven't done alot of of downgrading on my daily driver, only on my 3Gs that ive been using to toy around with. The wife doesnt let me play with her 4 that much, and i dont have mine anymore so... Try that.

    The reason i havent done any down grading on my current phone is....wait for it: its the 4S and we cant downgrade!!! To answer your question, yes, no JB sucks.
     
  7. vong thread starter macrumors 6502a

    vong

    Joined:
    Jan 31, 2010
    #7
    Can you list the steps you took to downgrading your iPhone? I am going to do it this weekend. iOS 5 is cool but I cannot see myself using the notification center or iCloud. 4.2.1 did everything that I need it to do.

    And how did you download your SHSH blobs?
     

Share This Page