Downgrading from JB 3.12 to JB 3.1?

Discussion in 'Jailbreaks and iOS Hacks' started by ninethirty, Nov 6, 2009.

  1. ninethirty macrumors 6502a

    Joined:
    Mar 1, 2006
    #1
    Hey Everyone,

    Ever since upgrading to 3.12 (JB) my battery life is beyond terrible. Others have mentioned that it is possible to downgrade to 3.1, which I plan to do today, but is there anything special I need to know about how to do this? Is there an older version of Pwnage tool I should use, or can I use redsn0w? What's the best way to go about doing this.

    Thanks in advance!
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    You need to restore to official Apple IPSW, choose set up as new (to get rid of JB gremlins) the re-JB if you plan to, again choose set up as new. Restoring to a backup brings the problems back with the restore.
     
  3. ninethirty thread starter macrumors 6502a

    Joined:
    Mar 1, 2006
    #3
    What's the best program to use to Jailbreak at 3.1 though?
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    If it were me, I would use Pwnage tool.

    Just point it at the 3.1 IPSW instead of the 3.1.2 IPSW.
     
  5. ninethirty thread starter macrumors 6502a

    Joined:
    Mar 1, 2006
    #5
    Ok, I restored to 3.1 - no problems, but when I use Pwnage tool now to create the new IPSW it tells me the wrong firmware bundle selected. I am of course pointing it towards the iPhone 3GS version of the 3.1 IPSW called this:

    iPhone2,1_3.1_7C144_Restore.ipsw

    ANy idea what I'm doing wrong?

    I tried Pwnage Tool 3.14 and 3.1

     
  6. jason221 macrumors 6502

    Joined:
    Jun 26, 2009
    #6
    Use the version of PwnageTool that was released for 3.1. I believe it's PwnageTool 3.1.2, not 3.1.4.
     
  7. cusco macrumors member

    Joined:
    Sep 20, 2009
    #8
  8. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #9
    Redsnow won't downgrade your software.
     
  9. cusco macrumors member

    Joined:
    Sep 20, 2009
    #10
    yeah, i found that out last night trying. So in this case, I can only use Pwnage and have it downgrade to 3.1?

    If yes, which version of pwnage should I use?
     
  10. cusco macrumors member

    Joined:
    Sep 20, 2009
    #11
  11. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #12
    Yes, he linked you to the 3G firmware instead of the 3GS. Just go to http://www.poorlad.com/iCommunity/ to download the correct version for your phone.
     
  12. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #13
    Already answered earlier in the thread
     
  13. cusco macrumors member

    Joined:
    Sep 20, 2009
    #14
    where can i find the pwnage tool 3.12? all i can find on the dev team site is for pwnage 3.1.4.

    thanks.
     
  14. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #15
    You know I can't remember if PT 3.1 worked for 3GS on 3.1 or not. There is a torrent link on DevTeam Blog, upper left corner.

    PT went from 3.1 to 3.1.3 to 3.1.4, there was no 3.1.2 so I should have read that reply closer as it was incorrect, which means my earlier post was in error. Sorry :(
     
  15. ninethirty thread starter macrumors 6502a

    Joined:
    Mar 1, 2006
    #16
    I managed to get Pwnage tool to create a proper IPSW for me, but I get an error in iTunes (after a long wait) when I try to install the package.

    I'm wondering.. I do have an ECID on file through Cydia.. do I need to make any changes to iTunes so it looks for the Cydia server instead of Apple to authenticate?

    Thanks!
     
  16. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #17
    Here is the info
     
  17. cusco macrumors member

    Joined:
    Sep 20, 2009
    #18
    would it be possible to use the pwnage tool to downgrade to 3.0 FW? or would 3.1 be the furthest back it will take you?
     
  18. aeaglex07 macrumors 6502

    aeaglex07

    Joined:
    Mar 18, 2007
    Location:
    United States
    #19
    i also want to downgrade back to 3.1. Does this method requite saurik's server cache like when you downgrade to 3.0?
     

Share This Page