Downgrading iOS 4.3.5 Problems

Discussion in 'Jailbreaks and iOS Hacks' started by AutomaticHaze, Sep 26, 2011.

  1. AutomaticHaze macrumors regular

    Joined:
    Aug 4, 2008
    Location:
    Texas
    #1
    I recently tried to downgrade my 4.3.5 iPhone 4, to 4.3.3
    I followed this tutorial, http://www.redmondpie.com/downgrade-4.3.5-ios-to-4.3.3-4.3.4-4.3.2-4.3.1-4.3-iphone-4-3gs-ipad-2-ipad-ipod-touch-4g-3g-how-to-tutorial/

    When i went to edit my hosts file, I noticed, unlike the example, mine already had this string of text: (#74.208.10.249 gs.apple.com) where I was supposed to paste the text from the example..which is ( 74.208.105.171 gs.apple.com ). Stupidly, I just pasted the text below what was already there and tried to downgrade.

    It finished, then I got the 1013 error. I tried to kick it out of recovery with TinyUmbrella and RecBoot, neither worked. So I ended up restoring the host file with the back up I had, and restored my phone to 4.3.5 back where I started.

    I have my SHSH blobs, at least I think.. before I updated to 4.3.5, I saved my blobs with tiny umbrella. It says I have 4.2.1 through 4.3.5 saved, so this should enable me to downgrade, correct?

    How would I get this to work?

    What did I do wrong or what do I need to change?

    Do I need to have my iPhone on 4.3.5 jailbroken to downgrade it?

    and last but not least, once I do get it downgraded will I be able to sync a back up from my iPhone on 4.3.5 of all my pictures, contacts and everything back on my phone?

    Sorry about the long post and all the questions! I've been jailbreaking for a long time, but have never downgraded.

    Thank you!
     
  2. AutomaticHaze thread starter macrumors regular

    Joined:
    Aug 4, 2008
    Location:
    Texas
    #2
    Pretty much figured out the problem, just need an answer on how to fix it.. problem is every time I open tiny umbrella I get the error: /etc/hosts file unwritable. I am the admin, and have checked the file to be "Read & Write" to everyone. On a macbook, running snow leopard. Any help would be great..
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    Weird, so TU and you have problems editing your hosts?
    If the restore to 4.3.3 goes thru use redsnow to JB it the way it is and it and will go thru and JB and kick it out of recovery.
     
  4. Trauma1 macrumors 6502a

    Joined:
    Jun 15, 2009
    #4
    I encountered the same problem. It's Apple's/iTunes' way of preventing you from doing what you're trying to do, and that overrides your admin privileges. There's two ways of editing the host file:

    Go into Terminal and type the following line:

    sudo nano /etc/hosts

    That should be able to let you add the text. Scroll down with your arrow keys, then cntl +O and cntrl + X to save and exit.

    The other way is to copy the host file to another destination (like the desktop), open it, edit it accordingly, then copy it back to the /etc/ folder and overwrite the original.

    Those are the two ways to edit the host file. That having been said, I'm still getting the 1013 error using TinyUmbrella. I'm on 4.3.5 and I'm trying to get to 4.3.3 with saved SHSH blobs. It seems all the guides I read have conflicting information: some say leave the hash-tag, some say take it out, some say leave a space between the hash-tag and the first number, etc. I get stuck in the recovery mode, even though I keep pressing the Exit Recovery on TU.
     
  5. AutomaticHaze thread starter macrumors regular

    Joined:
    Aug 4, 2008
    Location:
    Texas
    #5
    Same exact thing happening to me, all the guides say different things. Just tired to do it like I did the first time, editing the hosts file myself ( using the desktop method ) and this time it won't even let me restore, it says im not eligible.
    TinyUmbrella gives me the /etc/hosts unwriteable everytime, no matter what I do.

    So the method without TU isn't working for me now, and TU itself isn't working for me either. I guess i'm just throwing in the towel, i've tried everything I can! If you find out a method, please PM me. Thanks!
     
  6. Trauma1 macrumors 6502a

    Joined:
    Jun 15, 2009
    #6
    I would try reinstalling TU and restarting, if you haven't already.

    Did you ever have 4.3.3 installed on the phone? Because I didn't (I went from 4.1 JB to 4.3.5) and I'm wondering if this is the source of my errors.

    I've tried multiple times. As long as I can keep getting back to 4.3.5 I'll keep trying, using one thing different each time. I stopped messing with the host file a while ago and I just use the TSS server. I just can't get it out of the 1013 recovery mode error. The Fix Recovery button is not even enabled when the phone is in DFU mode. I may just leave it un-jailbroken in 4.3.5 and let the next person to get my phone deal with. The blobs are saved.
     
  7. AutomaticHaze thread starter macrumors regular

    Joined:
    Aug 4, 2008
    Location:
    Texas
    #7
    I did the exact same thing, from 4.1 JB to 4.3.5 Maybe that is an issue.. and if I uninstalled TU I wouldn't be able to get my blobs back would I? (since i'm on 4.3.5 unjailbroken)
     

Share This Page