Downgrading iPhone 2G ?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MacOSXuser, Dec 17, 2012.

  1. MacOSXuser macrumors regular

    Joined:
    Nov 1, 2007
    Location:
    Toronto
    #1
    Does anyone have a iPhone 2G and downgrade successfully?

    I have managed to downgrade from 3.1.2 to 1.1.4 in the past, but I don't remember how.

    Right now I have successfully made it to 3.0 from 3.1.3, by simply using the latest version of iTunes (11), DFU mode and option click each old firmware one by one. But I can't get below 3.0 . It's giving me 1600 error. Doesn't matter if the phone is in DFU, recovery or normal mode.

    I tried using older version of iTunes(8.1.2), but then it says the 'iPod software could not be contacted'.

    Can anyone give me insight how to downgrade it?

    Thanks
     
  2. MacOSXuser thread starter macrumors regular

    Joined:
    Nov 1, 2007
    Location:
    Toronto
  3. Tyler23 macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #3
    You need to have blobs saved, which it doesn't sound like you do.

    Without them, you can't downgrade to a firmware that Apple is no longer signing, and I guarantee they are no longer signing anything that low, they've already stopped signing 6.0 (I believe).

    So I don't think there will be a way for you to do it.
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Lol:D
    SHSH blobs didnt get implemented till the 3GS was released and they were never used for the original iphone 2G.
    What you were saying above is true for the iphone 3GS, i4, 4S and iphone 5 so you were partially there:D
     
  5. Tyler23 macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #5
    Ah, didn't realize that. Only been dealing with iPhones for the past 3 years so that's where my knowledge is :p So can the OP did what he/she is asking or is it not possible? Not only for their sake but also asking for my own knowledge.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    It can be done but not sure how low of firmware version he can get it go.
    Its a real pain in the rear since you will need very old itunes versions installed from 4+ years ago and have to play with some JB tools to get the firmware versions in and kicked out of recovery mode when they error out after the install etc...
    Some have gone to as low as 1.1.4 I believe but its not an easy or simple process.
     
  7. Brian Y macrumors 68040

    Joined:
    Oct 21, 2012
    #7
    1.1.4 is as far as you can physically go I believe - there are incompatibilities with the newer modem firmware that means if you do go below 1.1.4, the phone will never actually work as a phone.
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Good info.
    Not like I would ever bother using an iphone 2G but good to know for others:D
     

Share This Page