Downgrading iPod Touch 2G to 1.x Firmware, possible?

Discussion in 'iPod touch' started by t0264, Dec 15, 2010.

  1. t0264 macrumors newbie

    Joined:
    Dec 11, 2010
    #1
    There is a few apps I would like to run on my iPod Touch 2G, however they haven't been updated and therefore require 1.x Firmware to run. At the minute it's running iOS 4.0 (Jailbroken/Official Multitasking Modded On) but I plan on updating it to 4.1/4.2 anyway, haven't checked if there's a jailbreak or not but I'm not that bothered to be honest ;)
    My question is, if there's no way to patch 1.x apps to run on higher, is there a way to force flash my 2G iPod Touch onto 1.x firmware? Or is there anything else I could do?
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    There is no way to get 1.X apps to run on 2.+ or to get anything lower then 2.1.1 on an iPod Touch 2G.
     
  3. t0264 thread starter macrumors newbie

    Joined:
    Dec 11, 2010
    #3
    I don't know if it's possible, but is it possible to patch apps to work on 2.x+ or is this just a myth? :)
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    No, 1.X and 2.+ are very different when it comes to running applications. They only way is to completely rewrite the application with the new API that are there.
     
  5. t0264 thread starter macrumors newbie

    Joined:
    Dec 11, 2010
    #5
    Shame :( Thanks anyway :)
     

Share This Page