Downgrading to Leopard on a new 27" iMac

simonb1975

macrumors newbie
Original poster
Jul 23, 2010
6
0
Hi, please help

I have a new 27" 2.66Ghz Quad Core iMac which has got 10.6 installed. Does anyone know if I can go back and install 10.5?

Reason being, we run a content management system using quark 7.5 and are unable to upgrade to v8. There are operating issues running quark 7.5 on 10.6 and if I can go back to 10.5 that would solve everything.:confused:
 

slpdLoad

macrumors 6502a
Jun 10, 2009
664
0
In general, you should not install an operating system older than what the Mac originally shipped with, mostly due to drivers that are specific to your system and may not be present on the older OS.

For critical systems, you should have both hardware and software backups and test new upgrades before committing to them.

It may be possible to run 10.5, but you'll need to have an updated version (newer than 10.5.7 I believe). I would not recommend attempting to install directly from a Leopard retail disk on the new iMac.

Instead, you'll need a secondary temporary Mac that is capable of running Leopard. Boot the new iMac in Target Disk Mode, and boot the older Mac from the Leopard install disk. Connect the two computers with a FireWire cable, and install Leopard onto the new iMac's hard drive using the old Mac. After this completes, run a few rounds of Software Update to ensure that you are running a fully up-to-date 10.5.8. After this is complete, shut down the old both Macs, disconnect the cable, and start up the new iMac normally with its now-10.5.8 drive. If you're lucky, everything will work properly. But it may not even boot, and you will need to reinstall with the 10.6 restore media that shipped with it.
 

larkost

macrumors 6502a
Oct 13, 2007
536
1
There is absolutely no chance that 10.5 will be able to support the i5 or i7 iMacs (quad cores). It does not have the video card drivers nor the chipset drivers for lots of things on the motherboard (including the processor).

The bigger question is why you think you need to or should be doing this. That is probably the question that can be solved.
 

mac2x

macrumors 65816
Sep 19, 2009
1,147
0
In general, you should not install an operating system newer than what the Mac originally shipped with, mostly due to drivers that are specific to your system and may not be present on the older OS.

[...]
You mean older that what the machine shipped with, right?
 

wilsonlaidlaw

macrumors 6502
Oct 29, 2008
421
54
There is absolutely no chance that 10.5 will be able to support the i5 or i7 iMacs (quad cores). It does not have the video card drivers nor the chipset drivers for lots of things on the motherboard (including the processor).

The bigger question is why you think you need to or should be doing this. That is probably the question that can be solved.
We have 4 machines running Slow Leopard and 2 still running Leopard. No doubt at all in my mind, that Leopard is more stable, gets few SBOD's (Spinning Beachballs of Death), Airport issues, program freezes etc. I just hope that 10.7 (Faster Cat?) is better.

Wilson
 

simonb1975

macrumors newbie
Original poster
Jul 23, 2010
6
0
thanks for your comments, its a shame you can't revert to 10.5 but I can understand why. I can get around this by installing a previous version of Java (1.5) on 10.6 then our content management system is good to use...;)
 

peregrina

macrumors newbie
Nov 3, 2010
1
0
hmmm...

There is absolutely no chance that 10.5 will be able to support the i5 or i7 iMacs (quad cores). It does not have the video card drivers nor the chipset drivers for lots of things on the motherboard (including the processor).

The bigger question is why you think you need to or should be doing this. That is probably the question that can be solved.
I have a similar situation... DVDSP 4.1.2 is not stable in SL; but it works fine under 10.5.8
I don't edit video, so I only use DVDSP; and the upgrade is pricey
This is bad news from me :confused: