Downgrading to Mavericks leaves black screen on boot

Discussion in 'OS X Yosemite (10.10)' started by Paradoxally, Oct 3, 2014.

  1. Paradoxally, Oct 3, 2014
    Last edited: Oct 3, 2014

    Paradoxally macrumors 68000

    Joined:
    Feb 4, 2011
    #1
    Hello guys. I downloaded Yosemite GM, used createinstallmedia to create a USB stick with the installer, and clean installed Yosemite (deleting just the Mac partition, and leaving my bootcamp intact). When Yosemite first booted, it did 3 restarts - all of which showed the white Apple logo and then it finally booted into the setup procedure (I suspect the first 2 times it was upgrading the firmware or something). Now, whenever I booted Yosemite, it showed the new boot screen - black with a white Apple logo and progress bar instead of grey with a spinner.

    What happened next was that I decided I didn't like Yosemite, so I wiped my partition clean and installed Mavericks. The system boots, but when I press the power button, it STILL has the black screen (and if I hold Alt, it shows all my bootable drives with the black Yosemite boot screen, not a grey one like Mavericks). I have since wiped my SSD completely (with disk utility, 1 partition), reinstalled Mavericks, but that damned black boot screen will not disappear.

    When it boots into Mavericks, then the grey screen comes on and the Apple logo and spinner show. However, for a split second it shows black when booting and not white. Is this something embedded in the firmware? I suspect so, as doing an Internet recovery with cmd + R (to install Mavericks) shows an all black background with a grey globe. At that time, my SSD was completely wiped clean, so there was no OS on any partitions.

    I have tried messing around in boot.efi to no avail. I just can't get rid of the black boot screen.

    My Mac is a 13" mid-2014 retina MBP. Does anyone know how to remove this black screen entirely and go back to the grey Apple one when booting up and selecting partitions?

    I'm not happy at all about this. I don't want Yosemite's "remains" on my system until and if I decide to reinstall it.
     
  2. peabo macrumors regular

    Joined:
    Feb 14, 2008
    #2
    This is because the recovery partition on your HD must have not been wiped.

    You won't be able to see the recovery partition in Disk Utility, you have to erase the whole disk, not just the main partition to completely remove everything.
     
  3. Paradoxally thread starter macrumors 68000

    Joined:
    Feb 4, 2011
    #3
    Yes, I did this the second time and went to 'partition' instead of 'erase'. Now, when I boot and press alt it shows 'Recovery HD: 10.9' instead of 10.10 (I'm using a fresh Mavericks install). However, it still shows the black boot screen when pressing the power button and when I hold alt to display the partitions.
     
  4. peabo macrumors regular

    Joined:
    Feb 14, 2008
    #4
    You are meant to use Erase, just make sure you do it on the top level of the hierarchy which has the disk's size & make, not the named disk which is one level down.
     
  5. Paradoxally thread starter macrumors 68000

    Joined:
    Feb 4, 2011
    #5
    I did that too, partition, erase (on top level), my SSD has been completely wiped and has Mavericks now. I think that what controls the black boot screen is not residing on the SSD but in a separate part of the Mac. It certainly explains that even if you remove the SSD or wipe it completely, the newer Macs can still boot up and can go into Internet Recovery mode to install an OS without needing a USB stick. It is also there and before any partition is selected that the black boot screen appears. If I select to boot into Mavericks, it shows the grey screen as normal when it is booting.
     
  6. peabo macrumors regular

    Joined:
    Feb 14, 2008
    #6
    Ah, sorry I couldn't have been of more help. Not sure what else to do.
     
  7. kalmira macrumors newbie

    kalmira

    Joined:
    Oct 20, 2014
    #7
    Same issue here, I tried everything but no luck :(
    Seems to be a firmware update made by OS X Yosemite.
    Any sugestions?
     
  8. Introvert macrumors newbie

    Joined:
    Oct 5, 2013
    #8
    I've looked everywhere and tried absolutely everything to restore my grey boot screen for Mavericks - with no luck.

    I initially thought it was an EFI update on a hidden disk partition. I tried completely erasing my disk - even going as far as booting into Gparted and manually wiping the partition structure.

    I've tried Cmd + Option + R for internet recovery but it boots a black globe screen as it downloads the initial shipping restore partition.

    Basically, the black boot update with all of the horrible greenish grey tint Yosemite disk icons (etc.) has been updated at a hardware level. The Yosemite updater seems to have flashed a chip on the mac that isn't related to the hard drive - at a firmware/bios level.

    This is really frustrating as I'm now left with an initial Yosemite black boot screen that changes to grey as Mavericks boots.

    I hope that Apple release a firmware downgrade tool for people who want to restore their Macs to a pre-Yosemite state - but I wouldn't hold my breath.

    Here's hoping.
     
  9. YanniDepp macrumors 6502

    YanniDepp

    Joined:
    Dec 10, 2008
    #9
    Yep, Yosemite comes with EFI and SMC updates, but only for certain models of Macs.

    I've never tried downgrading Mac firmware, but it sounds like something I wouldn't recommend. Failed firmware changes can mean totally bricked, unrecoverable logic boards.
     
  10. CyBeRino macrumors 6502a

    Joined:
    Jun 18, 2011
    #10
    The black boot screen is in the firmware. You won't be able to remove it, and it won't affect how Mavericks functions.
     
  11. Introvert macrumors newbie

    Joined:
    Oct 5, 2013
    #11
    You're absolutely right. It doesn't affect how Mavericks functions at all, but affects visual parity. You're now stuck between two worlds. A Yosemite skinned firmware and a Mavericks OS.

    It's one for the purists. If I'm on Mavericks, I want the boot experience to feel like it should on Mavericks - with a grey booting firmware and Mavericks disk icons if I hold the option key on boot.

    If I'm on Yosemite, I'm happy with the black boot screen because it visually works with Yosemite's black startup design.

    Now we're stuck with the initial black boot regardless. It's fine, I'll get used to it.

    I'm trying to think of the positives. One is that if you have a BootCamp partition, you now get an initial black boot screen instead of it starting grey then switching to black - which is kinda cool.

    Basically, once you install Yosemite there's no way back. You'll have an updated Yosemite firmware with an initial black boot screen regardless of what previous OS you're running.
     
  12. Introvert macrumors newbie

    Joined:
    Oct 5, 2013
    #12
    The black Yosemite boot screen right through to 10.10 startup is an interesting move.

    1. It looks fresh against the black hardware frame of an iMac or MacBook Pro.

    2. It's a new way to quickly detect dead pixels on a new Mac ;)
     
  13. kalmira macrumors newbie

    kalmira

    Joined:
    Oct 20, 2014
    #13
    How about making a EFI / SMC dump from a not yet updated Mac?
    I have a rMBP mid 2014, and two of my friends have the same machine, but not updated yet to Yosemite.
    It is possible to dump the firmware using tools like Flashrom?:rolleyes:
     
  14. knmdk macrumors newbie

    Joined:
    Dec 12, 2012
    #14
    Beware: installing Mac EFI Security Update 2015-001 on OS X 10.9.5 will update your Boot ROM UI to Yosemite/El Capitan style without notification. So now there's no need to update OS X to get new "different" new icons and black screen instead of classic Mavericks Boot ROM UI. Unfortunately I absolutely don't new look and wish to downgrade. In case someone was able to downgrade EFI Boot ROM firmware of 15-inch rMBP please post the solution. I wasn't lucky enough.
     

Share This Page