Download issue

Discussion in 'Mac Basics and Help' started by Bosox3, May 23, 2009.

  1. Bosox3 macrumors regular

    Bosox3

    Joined:
    Feb 7, 2007
    #1
    Ive been having this issue now for some tima and cant figure out why its going on.
    When I try to click on a link to download something, nothing happens. It opens another screen and stays blank.
    I end up having to right click and save link location.

    does anyone know whats going on or why it might be doing this?
     
  2. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
  3. Tomorrow macrumors 604

    Tomorrow

    Joined:
    Mar 2, 2008
    Location:
    Always a day away
    #3
    Your browser's settings might be set to "open links in a new window." Change the setting and see what happens.

    Also, are you by chance middle-clicking?
     
  4. Bosox3 thread starter macrumors regular

    Bosox3

    Joined:
    Feb 7, 2007
    #4
    Firefox


    I'll check my settings...maybe I messed w/ them and didnt realize.
     
  5. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #5
    try changing your downloads folder in the FF preferences.
    Otherwise, you can try removing ~/Library/Preferences/com.apple.internetconfig.plist
     
  6. surflordca macrumors 6502a

    surflordca

    Joined:
    Nov 16, 2007
    Location:
    Ontario, Canada
    #6
    Do you "No Scripts" or other security plug-in running?
     
  7. Bosox3 thread starter macrumors regular

    Bosox3

    Joined:
    Feb 7, 2007
    #7
    Thanks everyone.

    I did alittle looking around and found that it was some Speed Download app I had installed. I guess its known to have issues like this.
    SO I removed it and everything is back to normal. :D
     

Share This Page