Download stalling at 778MB

Discussion in 'Mac Apps and Mac App Store' started by Pikachu4170, Jul 26, 2014.

  1. Pikachu4170, Jul 26, 2014
    Last edited: Jul 27, 2014

    Pikachu4170 macrumors member

    Joined:
    Jun 24, 2013
    #1
    I am downloading the OS X Yosemite Public Beta from the Mac App Store, but it seems to freeze at around 778MB for a few minutes.

    After that, it continues downloading slowly until 786MB and then it bounces back to 778MB.

    I resetted the download twice and it still seems to have the same issue.

    Assuming it's my connection or the App Store's CDN or traffic?

    (This was originally meant to be on Apple Support forums, but it was rejected due to beta material)
     
  2. 2902326 macrumors newbie

    Joined:
    Apr 2, 2013
    #2
    I'm having exactly the same issue, I've tried to download the beta on a MacBook and an iMac, both start the download fine and then stall at 778mb.

    I've tried deleting the partially downloaded files and restarting the download, this hasn't solved the issue either. I've tried downloading the file with a different account and I still haven't had any success. Any help would be greatly appreciated.

    I really hope Apple sorts out the App store, it's always very slow and I've had problems with downloads from day one. My computers are fine and I have a decent internet connection so I think the problem is at Apples end.
     
  3. Larry-K macrumors 68000

    Joined:
    Jun 28, 2011
    #3
    Yeah, that system on a DVD thing was so inconvenient, much more fun downloading the system again and again.

    Apple always acts like everybody is on the Apple Campus when it comes to downloads, and a lot of the time it's an excruciatingly tedious experience for real world users.
     
  4. Pikachu4170 thread starter macrumors member

    Joined:
    Jun 24, 2013
    #4
    I mailed the issue to Apple Support.

    Estimated tomorrow.
     
  5. 2902326 macrumors newbie

    Joined:
    Apr 2, 2013
    #5
    I managed to solve the issue by connecting to a different wireless network and resuming the hung download. I then paused the download and switched to the original network and the download proceeded without fault.

    May I suggest that people try this and see if they have any luck? An alternative would be to use a wired connection although I haven't tested that method.
     
  6. Pikachu4170 thread starter macrumors member

    Joined:
    Jun 24, 2013
    #6
    I mostly use a wired connection in my home for huge downloads as Wi-Fi can commonly have issues.

    I was connected in a wired connection when I was downloading the beta and it has the effect. Maybe disconnect the wired connection and connect to wireless and back should do it. Also try changing IP address.
     
  7. Pikachu4170 thread starter macrumors member

    Joined:
    Jun 24, 2013
    #7
    Got a reply from one of Apple Support's boys (Jeez, people are so lazy now-a-days). They say it's my network having issues.

    But my connection is decent enough (~1 Megabyte/sec.) and can download the beta in ~2 hours.

    Anybody think Apple's auto-response was incorrect?
     
  8. Glynthomas86 macrumors newbie

    Joined:
    Aug 15, 2014
    #8
    This worked for me. I switched between wifi and my iPhone hotspot.

    ----------

    Oh and thanks for the tip.
     

Share This Page