Download Xcode 4 once, install multiple times?

Discussion in 'Mac Apps and Mac App Store' started by ansalmo, Mar 10, 2011.

  1. ansalmo macrumors regular

    Joined:
    May 23, 2005
    #1
    With Xcode 3, I'd download it to a network share and update my Macs locally. Now that Xcode 4 comes via the App Store, the standard installation process means that I'd need to download it once for each Mac - that's fine for most apps, but Xcode 4 is over 4GB. That takes several hours and burns through masses of bandwidth, and presumably I'll have to go through the same process every time Apple release updates.

    Is there a more efficient way to do this? Maybe a download package I can move from one machine onto others? They're all using the same App Store account by the way.
     
  2. pigloo9 macrumors newbie

    Joined:
    Nov 9, 2010
    #2
    I'd like to know too... an 'offline' install option would be helpful especially for applications of this size. For instance, software updates can be found on the Apple website to download & install on several macs later.
     
  3. Mal macrumors 603

    Mal

    Joined:
    Jan 6, 2002
    Location:
    Orlando
    #3
    You should just be able to drag-and-drop the Xcode 4 .app to each of the other computers over the network or put it on an external drive and transfer it that way. It'll simply ask you to authorize it on each computer when you first run it there.

    jW
     
  4. ansalmo thread starter macrumors regular

    Joined:
    May 23, 2005
    #4
    OK, thanks, I'll try that.
     
  5. northerngit macrumors member

    Joined:
    Jul 16, 2007
    Location:
    England
    #5
    The Xcode.app is not a stand alone bundle. Xcode unpacks to /Developer

    I would suggest you look in your Applications folder for a file:

    "Install Xcode.app"

    This is a 4.58GB bundle that may be transferred to each machine, rather than downloading such large content on each machine via your App store account.

    Let us know if it works.
     
  6. MacOSExustio, Jul 26, 2011
    Last edited: Jul 26, 2011

    MacOSExustio macrumors newbie

    Joined:
    Sep 7, 2010
    #6
    Copy xCode 4.0 Installer app - *read* error??

    I tried this, copying over a home network, and got an "Don't have permission to *read*" error (emphasis mine).. What the heck does this mean? Everything looks like it's Read/Write for the owner, and Read for everyone else. I even managed to copy all the individual parts of the application bundle folder, but the "reconstructed" bundle didn't want to run. The error seemed to have something to do with trying to copy the entire "Resources/Packages" directory at once - but I have no idea what (again, each individual file would copy, but not all of them at once).

    I suspected there was some kind of "nuisance copy protection" (meaning it can be gotten around easily..) for anything downloaded from the App Store - but I suspect not as the individual parts of the bundle will copy.

    The error when I tried to run the "reconstructed copy" was not being able to find a principle class name in Info.plist.. Even though Info.plist copies just fine - like everything else.

    I must say that I don't have much space on the destination disk (only 7 GB free, for a file that is 4 GB), and have many "disk almost full" errors (when Safari has created 3 GB of cache files..). So there is probably disk corruption somewhere that might be causing a problem. Still, if it were a disk corruption problem, I wouldn't expect it to fail at the *beginning*, and not fail on the *read*.

    Edit

    Found it - it was in the hidden file /Resources/.changedIcons It's a zero-K file; no idea what it does - perhaps something that should have been deleted. Deleted it and it burned to a DVD fine.

    Jim
     

Share This Page