Downloaded apps not running, returns me to home screen

Discussion in 'iPhone Tips, Help and Troubleshooting' started by budpaul, Jul 11, 2008.

  1. budpaul macrumors newbie

    Joined:
    Jul 11, 2008
    #1
    I've downloaded a number of applications, including Monkeyball, Weatherbug and Enigmo, but when I press them I go to a loading screen for a few seconds and then and brought back to the home screen. I read on another forum of someone having a similar problem and they were able to solve it by turning their phone off and on; this solution did not work for me. I've downloaded a couple of other apps (AIM, iPhone Saber) which worked for me before but now the same thing is occurring.
    Has this happened to anyone else? Any ideas? Oh, I'm working with iPhone Classic with the obviously updated firmware.
     
  2. julamoor macrumors newbie

    Joined:
    Jul 11, 2008
    #2
    You're not alone.
    I upgraded iTunes, installed iPhone 2.0, then used the phone to buy/download several applications. They worked fine.

    Then I went to sync via iTunes and the apps all stopped working. I'll click on one, it will begin to launch, then almost immediately go back to the home screen. Things I have tried with no success:
    1. Turning iPhone on off
    2. Doing a hard reset on the iPhone
    3. Resetting via iPhone settings
    4. Restoring the phone via iTunes

    Running out of options. Help?
     
  3. xfsasx macrumors member

    Joined:
    Jun 27, 2007
    #3
    this happened to me but only in certain apps.

    I rebooted the phone and it was fine
     
  4. budpaul thread starter macrumors newbie

    Joined:
    Jul 11, 2008
    #4
    Here's what I tried. I synced my phone but without anything checked - no music, no movies, no contacts and no apps. This basically wiped the phone clean. I then started one at a time checking an app then syncing the phone. I'm now going back and reloading my music and contacts, but I do not expect any problems.
    One note, there are two apps that I did not reload - Phone Saber and Where - not sure why I didn't other than maybe I just didn't want to push my luck plus they're two programs that were free and I don't really need.
    Give it a try and see if it helps you, julamoor.
     
  5. marksman macrumors 603

    marksman

    Joined:
    Jun 4, 2007
    #5
    I had apps on my v1 phone yesterday. When I got my new phone I did a restore from that phone. All the applications were on there but none of them worked.

    So I did a sync and left all the applications off. I then went and re-downloaded them all over wifi directly to the phone and they all work fine now.

    So I would just remove all of them from the phone and re-download them.
     
  6. lertulo macrumors newbie

    Joined:
    Jul 11, 2008
    #6
    Exact same problem. Common theme seems to be Enigmo: bought and used two apps fine, bought Enigmo and found it always crashed back to iPhone menu. Tried rebooting the phone 3 times (as suggested by the Enigmo web site), and now I see that none of my apps run. WTF?
     
  7. 03sho macrumors 6502a

    Joined:
    Sep 19, 2007
    Location:
    UK
  8. JupiterTwo macrumors 6502

    JupiterTwo

    Joined:
    Mar 29, 2003
    Location:
    GB
    #8
    yep, removing the apps from my iPhone and then adding the apps back in iTunes worked for me.
     
  9. duncanm macrumors member

    Joined:
    Jun 7, 2008
    #9
    This has now happened twice to me. Indeed, removing the applications and reloading does solve the problem, but it seems to be a temporary fix. I hope this is a bug with 2.0 firmware and not coding problems within actual programs which then have the ability to cripple all 3rd party applications.

    If anyone has any information on the details behind why these programs crash in such a system wide manner, please chime in.

    Note: Only 3rd party applications are affected. All native 2.0 apps remain stable and fully functional.
     
  10. xzmk07 macrumors newbie

    Joined:
    Jul 17, 2008
    #10
    The same problem has been happening to me. Super Monkey Ball and Aurora Feint have been crashing each time I open it and it returns to the home screen. Turning the phone off and back on seems to fix the problem, but then it starts happening again hours later. I hope they fix this in 2.0.1.
     
  11. AJsAWiz macrumors 68040

    AJsAWiz

    Joined:
    Jun 28, 2007
    Location:
    Ohio
    #11
    The guy at the Apple Store Genius Bar claimed this was due to the way application memory is handled on the iPhone. :apple:
     

Share This Page