Downloaded some software, now getting pop-ups

Discussion in 'macOS' started by shawnperson, Apr 12, 2010.

  1. shawnperson macrumors newbie

    Joined:
    Apr 11, 2010
    #1
    So, I downloaded " Safari AdBlocker" from the Apple Store (http://www.apple.com/downloads/macosx/internet_utilities/safariadblocker.html) and it didn't go well. It installed but nothing changed, this is not the first thing that I have installed so I don't think that was a problem, I just felt odd about it,so I uninstalled it. Today I had some pop-ups. Can this AdBlocker be the cause. I should ad that it's not a lot of pop-ups, but some. This is my first Mac so I don't know what I'm doing and I don't know what I'm asking. Any help would be appreciated, thanks.
     
  2. Dwalls90 macrumors 601

    Dwalls90

    Joined:
    Feb 5, 2009
    #2
    You can use the pop-up blocker feature in Safari ... no need for a third-party app. Uninstall that and restart, and enable pop up blocker in Safari.
     
  3. shawnperson thread starter macrumors newbie

    Joined:
    Apr 11, 2010
    #3
    Hi thanks for the reply. I have pop-ups blocked that is an add blocker. don't know if I need it but I had it on my old p.c. with Firefox. The pop-ups are getting bad, what should I do? Reinstall Safari? Get iAntiVirus? Reinstall OS X? I thought downloading something from the Apple site would be OK...but maybe not.

    " the Google Safe Browsing Service is unavailable. No updates have occurred in 1 day" That is from the Safari Security preferences.
     
  4. boyshark macrumors newbie

    Joined:
    Apr 15, 2010
    #4
    Google Safe Browsing Not Available

    I'm also somewhat new to Mac, but learning quickly. I found this same problem on my Mac this afternoon - have never seen it previously. No new software downloads, the most recent installation was the newest security update from Apple. The one thing I recently changed was in System Preferences in the Security Section. I had the firewall running previously, but recently added Stealth Mode to my settings (just as a precaution based on articles I read). After finding the Google problem this morning, I did a search for the issue and found the forums here - read the posts on this subject as far back as I could find. Nothing anyone else spoke of seemed to apply to me - no new installs, never had the problem before, had tried resetting Safari, restarting computer, and so on. The only thing I could think of was the newest update from Apple (which installed last night before I went to bed) - and I remembered changing the security setting about 2 days ago. I went to Firewall Settings, removed the check from "Stealth Mode". After removing the checkmark, I went back to Safari, expecting that I would need to restart Safari and maybe even restart my Mac, but to my surprise the yellow triangle was gone.

    I don't know enough about Mac to say for sure this is the solution for everyone else - just adding my experience & hoping maybe it helps someone out there.
     
  5. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #5
    You could remove all your cookies by going to Safari Preferences>Security>Show Cookies>Remove All.
     

Share This Page