Downloading issue - No idea

Discussion in 'Mac Basics and Help' started by tommy6404, Dec 17, 2008.

  1. tommy6404 macrumors newbie

    Joined:
    Dec 17, 2008
    #1
    I have been using a mac for over a few months now, and I am very comfortable using a mac. There is one issue though, and that is when I try to download things, sometimes after I click the link, nothing happens... it shows that the page is loading, everything moving as it should, but the window to start downloading never pops up! I have been to my college downloading website, and I was wanting to download a large file, but when I clicked it, the file never came and I tried over and over again for 4 hours, being patient for a while, and then trying it again... Now I am trying to do it again, and it is stopping me once more and I hope there is some easy solution to my problem. I'm trying to download LiquidMac, and it WILL NOT LET ME DOWNLOAD IT!!!!

    Please, any help would be appreciated,
    :apple:-Tommy-:apple:
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Hmm, weird. Try right/control-clicking on a link and selecting "copy link". Open a Terminal window and type "curl ", then paste the link in. You should get a fair bit of gibberish; as soon as it starts coming down you can press control-C to quit it. I'm just suggesting that as a test, although you can use curl to download files in a pinch.
     
  3. tommy6404 thread starter macrumors newbie

    Joined:
    Dec 17, 2008
    #3
    I tried it, but it didn't work. It did give me the gibberish, and then it didn't do anything... I did find the word "paypal" within the text though (it was near the bottom) I wish I could go see a genius about it, but I do not live ANYWHERE near a genius bar.... I live 90 miles away from one! God I want this fixed!
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
    Go to macupdate.com andsearch for the thing and download it.

    You can also hold on to the OPTION key while you click on the link that gives you gibberish.
     
  5. tommy6404 thread starter macrumors newbie

    Joined:
    Dec 17, 2008
    #5
    THAT WORKED PERFECTLY!!!! THANKS BRO!!!! :D:D:D
     

Share This Page