Downloading stops my Mac from web browsing

Discussion in 'OS X Mavericks (10.9)' started by yourmn, Feb 11, 2014.

  1. yourmn macrumors regular

    Joined:
    Jun 28, 2010
    Location:
    United Kingdom
    #1
    Hi

    I've got a strange problem.

    Whenever I download a file through Safari, or even a Torrent via utorrent, I am unable to browse the internet. The files keep downloading in the background, and the speed of the download doesn't appear to change.

    When I go to visit a webpage, I get a long hang where Safari is looking for the website, but thats where it stays. I have however noticed, that if i click on my Wireless Network from the Network list on the top menu, that the website then loads?! However a few seconds later it stops again.

    This keeps on happening until whatever I am downloading has finished.

    Any ideas?
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Have you limited the UPLOAD speed in µTorrent, because the UPLOAD speed is the one limiting your download speed in browsers, if the UPLOAD speeds is at your upload speed capacity.

    If no µTorrent is running and you just download a file via a browser, your browsing speeds should not be hindered by that.

    If that is so, go to Activity Monitor > Network > Data sent/sec and report back.
     
  3. yourmn thread starter macrumors regular

    Joined:
    Jun 28, 2010
    Location:
    United Kingdom
    #3
    Hi

    I get the same problem if uTorrent is closed. I've just done a test download through Safari on my MacBook Air, and once again I can download the file (4.1MB/s) but cannot browse to any website. This is a screen shot of activity manager.

    It happens on both my Macs, so this is making me think it could be a problem with my Time Capsule?
     

    Attached Files:

  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    From your screenshot it seems something is uploading at roughly 110 KB/s. Do you know, what upload speed capabilities you have?
     
  5. yourmn thread starter macrumors regular

    Joined:
    Jun 28, 2010
    Location:
    United Kingdom
    #5
    My broadband package is a 70mb download and 20mb upload. I've done a speed test and it says I've got an upload speed of 18.75megabits

    I've no idea what is uploading, although I do have a plex server running on the iMac
     
  6. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #6
    Then even 100 KB/s should not make any impact, if you can upload at 2 MB/s. As for the download speed, 4 MB/s is half of your capabilities.
    Maybe reset Safari or try another browser?
    Maybe it is some setting somewhere.
     

Share This Page