Downloads routinely fail to complete

Discussion in 'OS X Mavericks (10.9)' started by Fairfax, Dec 28, 2013.

  1. Fairfax macrumors member

    Joined:
    Aug 15, 2011
    Location:
    Deep Web
    #1
    Hello,

    For whatever reason about 6 times out of 10 I am unable to successfully complete downloading a files that is larger than 200MB. At times what will happen is that I check the status of the download, I see that safari no longer shows the download speed and the status of the file size stops increasing and the download is essentially frozen in place. Other times I will see a curved arrow in an orange circle letting me know the download has failed and letting me know I can restart the download, when I see the curved arrow it is accompanied with the following message "the network connection was lost". The weird thing is that at the same time of the download i am watching Netflix instant and browsing other sites, everything loads fine and i never appear to lose connection and the wifi signal in the menu bar shows a strong signal and that i am currently connected to the internet.

    When I try to download in Firefox, the download again freezes and then I am forced to download files using an older macbook pro running Snow Leopard and while using Snow Leopard I am able to complete the download. Any idea what I can do to prevent downloads from failing when all signs point to that I am connected to the internet?

    Thanks in advance for your help.
     
  2. cerberusss macrumors 6502a

    cerberusss

    Joined:
    Aug 25, 2013
    Location:
    The Netherlands
    #2
    It's not something simple like a disk space problem, right? I guess not.

    And other browsers give the same result? Have you tried opening terminal and using the curl command to download these larger files?

    The same Mavericks notebook on a different network, does it give the same problem? I.e. it is really the notebook itself, not the combination of notebook and router?

    I'd also be curious if it happens when simply using a UTP cable.
     

Share This Page