DP2 keyboard media keys

Discussion in 'OS X Yosemite (10.10)' started by ncrypt, Jun 19, 2014.

  1. ncrypt macrumors 6502

    Joined:
    May 16, 2012
    Location:
    UK
    #1
    Has anyone else found that since DP2, the media keys (previous, play, next), aren't functioning with iTunes? The rest of the function keys are working fine however...
     
  2. dmccloud macrumors 6502a

    dmccloud

    Joined:
    Sep 7, 2009
    Location:
    Anchorage, AK
    #2
    Just tested the keys on my machine and they're working normally. What version of iTunes are you running?
     
  3. 53kyle macrumors 65816

    53kyle

    Joined:
    Mar 27, 2012
    Location:
    Sebastopol, CA
    #3
    I just tested my media keys, and to my surprise, they worked! For some reason, the only media key that functioned on my MBP with mavericks was the play/pause button. On yosemite, the rest of them work now.

    I would reinstall the OS in the OP's case.
     
  4. SmOgER macrumors 6502a

    Joined:
    Jun 2, 2014
    #4
    Is it just the itunes or everything? Do they work in spotify?
     
  5. ncrypt thread starter macrumors 6502

    Joined:
    May 16, 2012
    Location:
    UK
    #5
    iTunes 11.2.2

    Just iTunes. I don't know about spotify but they're working for VLC
     
  6. yokken macrumors member

    yokken

    Joined:
    Feb 3, 2013
    #6
    I have this same problem. When I booted back into my Mavericks partition I couldn't use my media keys for iTunes anymore. It works for VLC but not Vox or iTunes. Pretty frustrating. Has anyone tried a PRAM reset?
     
  7. swindlenz macrumors member

    Joined:
    May 18, 2013
    #7
    Did anyone having this problem use gTunes, and use the DMG they provide to disable the keys for iTunes so they work with gTunes?

    I used the gTunes MediaKeyDisabler so the keys wouldn't work with iTunes so I could use them with gTunes. They still work with gTunes but not iTunes anymore. See, I ran this DMG to disable these keys, but a few days later wiped my HDD to do a clean install of 10.10. Since then, I can't get them working with iTunes again.


    I wonder if something has stuck through the clean install and now these keys may never work again? :(
     
  8. ncrypt thread starter macrumors 6502

    Joined:
    May 16, 2012
    Location:
    UK
    #8
    I found that the issue randomly disappeared again after a couple of days. Can't figure out why though
     
  9. yokken, Jun 26, 2014
    Last edited: Jun 29, 2014

    yokken macrumors member

    yokken

    Joined:
    Feb 3, 2013
    #9
    Well that's not encouraging. I guess I'll just wait for them to come back...

    EGADS! I discovered that the media keys work in iTunes if Chrome is closed. I can't find any setting in Chrome that would take those keys over, so I don't know what to do, short of doing a full reset on my Chrome settings.
     
  10. yokken macrumors member

    yokken

    Joined:
    Feb 3, 2013
    #10
    Really? No one else has had this issue? I find that hard to believe... I think it happened when I updated iTunes to 11.2.2 or whatever on my Yosemite install (via external SSD/Thunderbolt enclosure). I made a symlink to my Music directory on my Mavericks install so I had all my music in Yosemite. I tried replacing my iTunes files with a backup from a week ago and it didn't fix it. I have no idea what the problem is but it's REALLY bugging me. Almost to the point of reinstalling Mavericks on my main drive.
     
  11. yokken macrumors member

    yokken

    Joined:
    Feb 3, 2013
    #11
    I FIXED IT. Thanks to the person on Apple support forums!!!

    https://discussions.apple.com/message/25950196

    I just changed the Google Play Music keyboard shortcuts in Chrome (under Extensions) to "Chrome Only" and now my iTunes media keys work again. Order has been restored to my life.
     

Share This Page