DP3 install hangs..(MBP 2011) and so does DP4!

Discussion in 'Mac OS X Lion (10.7)' started by funkyfresh69, May 19, 2011.

  1. funkyfresh69, May 19, 2011
    Last edited: Jun 8, 2011

    funkyfresh69 macrumors member

    Mar 25, 2011
    Currently on DP2 with latest updates.

    I downloaded DP3 and run the installer (from within DP2). The installer does its thing and the machine restarts, but then just hangs.

    In verbose boot mode it gets to loading the Ethernet driver , I think (with my little knowledge of UNIX)

    This happens whether I install DP3 onto the same partition as DP2 - i.e. an upgrade or into a separate partition)

    I’ve even booted from an external USB drive into DP2, then run the DP3 installer and pointed it at the internal drive. No joy...
    Also tried cold booting from the dmg contained with the installer.app and it hangs at same point.

    Anyone else having same issue?
  2. KaraThrace macrumors newbie

    May 30, 2011
    Yep. Mine hangs on loading the wireless drivers... Just freezes.
  3. waveen, Jun 7, 2011
    Last edited: Jun 7, 2011

    waveen macrumors newbie

    Oct 12, 2007
    Any solution Yet ?

    I have the some problem, looking at the verbose log it looks like the installer is hanging on the ethernet or wireless drivers.
    (also MBP 2011 (17"))

    -- Update --

    After trying a lot of different stuff, i finally got Lion up and running. I installed Lion on the MBP using an other Mac (iMac) with the MBP attached to it in 'target disk mode'. Next i repaired the disk permissions on the MBP via the iMac. The first reboot hung, but the second reboot (in verbose mode) started ...

    Hope everything stays stable now ....
  4. waslallah macrumors newbie

    Jun 7, 2011
    mine istalls just fine, but it won't boot. i booted on to SL, then delete IO80211Family.kext . from the lion hd.

    the Path: (root)/System/Library/Extensions/IO80211Family.kext

    then, the system boot just fine with no problems, though with no Airport. Finally, istall IO80211Family.kext using Kext help, to recover the airport, now everything seems to be fine.

    (the Machine is Macbook pro, early 2011 running Lion DP4 ).
  5. funkyfresh69, Jun 8, 2011
    Last edited: Jun 8, 2011

    funkyfresh69 thread starter macrumors member

    Mar 25, 2011
    The only way I get DP3 to install (which I’ve had to do twice again) was to use SW update to get the updates one by one - eventually ending up on build 11A459e

    Yesterday I tried to install DP4. I tried the DP4 App from App store, selecting the dp3 partition as target. It reboots and freezes with the spinning gear.

    So, after yet another frigging rebuild (i.e. start with SL, then install DP2 onto new partition, then run sw update 3 or 4 times, then restore apps/settings from a TM backup) I’m back where I was on DP3:mad:

    Apple have some serious work to do before its even a GM, as far as my experience tells me.

    I ran with all the Windows 7 betas from very early on, and tbh they came out (leaked) quicker. Each time they got better and less people had issues. Obviously Apple don’t release so many builds publicly, but for me, I see less progress than I’d expect, especially now they have an impending release date.

    Finally, a little rant!
    No DMG? That’s not going to be fun for anyone who’s HDD has a hardware problem and need bootable media. (recovery partitions arent gonna help here are they?!!)
    Even if they offer an easy way to create media - a-la cheap windows PC and a “wizard” to create installation media (USB or DVD) , its very arrogant to expect everyone to have sufficient, stable bandwidth to DL an app/package/whatever to create the media. And virtually everyone I know doesnt bother to do this and ignores the wizard reminders on Windows machines..

    It can only be being released in App store initially - physical media of some description will have to me made available.
  6. iMacDragon macrumors 68000


    Oct 18, 2008
    There is a DMG, it's just hidden inside the installer package.
  7. munakib macrumors 6502

    May 22, 2011
    I was having issue installing DP3 and DP4 (using a USB drive) too, having a blank white screen, but what I did wrong was I took out the usb drive before the 2nd restart (after installation was completed).

    Are you all keeping your Installation CD/DVD's/USB's plunged in throughout the installation? If not try doing it. It worked for me after that.
  8. ddoolin0 macrumors regular

    Feb 24, 2011
    I can't even get mine to start. It says I can't install on this computer. When I boot from a disc, I get a Cancel at boot.
  9. ReallyOldGuy macrumors regular


    Jan 26, 2010
    mine hangs (4) during installation, after restart, 30 mins to go, while "checking for disk" says "Fail" but the tiny gear keeps spinning checking disk.
  10. phpmaven macrumors 68040


    Jun 12, 2009
    San Clemente, CA USA
    Just in case some of you are not aware, the installer has been updated to fix the MBP 2011 issues that many were having with the wifi as well as other problems. It installs build #11A480e as opposed to the original build# 11A480b.

Share This Page