DP4 Update 11A494a,hotkey ctrl-a is disabled?

Discussion in 'Mac OS X Lion (10.7)' started by arnehuo, Jun 17, 2011.

  1. arnehuo macrumors newbie

    Dec 1, 2010
    When update lion to 11A494a,hot-key ctrl-a is disabled.Is it a bug?My macbook pro is 13-inch, Mid 2010.
    guys,Have you happened?
  2. MacManiac76 macrumors 65816


    Apr 21, 2007
    White Mntns, Arizona
    What is Control-A supposed to do? I know Command-A is a select all command, but have never used Control-A for anything ever.
  3. nephilim7 macrumors regular

    Jun 13, 2008
    well... control A has no generic use...

    unless you use emacs =/ or screen.... or.. even going to the beginning of a line in shell.


    at least they exposed the control up arrow binding so you can tell it to stop launching mission control. but no ctrl-a = suck. It's being blocked somewhere high up because it isn't being passed to vm's either.
  4. itickings macrumors 6502a


    Apr 14, 2007
    What? Are you kidding me? CTRL-A removed? :eek:

    I use CTRL-A / CTRL-E all the time, for text fields, text boxes and other stuff, in Safari, Firefox, Pages, Terminal, etc, and so on. I realize how often I use it when I use some odd applications like Word when I annoyed that it doesn't work.

    Hopefully a bug that'll get fixed.
  5. arnehuo thread starter macrumors newbie

    Dec 1, 2010
    ctrl-a is good on a new installation mac lion DP4 11A480e.After I updated to 11A494a,it's wrong.:(
  6. CyBeRino macrumors 6502a

    Jun 18, 2011
    It moves to the beginning of the line in anything that supports emacs key bindings (which Cocoa does.)

    Anyway. Ctrl-a being probably the key combo that I use most of anything ever, I set out to figure out what was causing this the moment I ran into the problem.

    It is indeed being caught somewhere very high up as it just did not register anywhere, except on another computer through Teleport. That was literally the only place it still worked.

    You can fix this problem by deleting the following plist file, which will reset all your keyboard shortcuts: com.apple.symbolichotkeys.plist in ~/Library/Preferences, and then logging out and back in again.
  7. arnehuo thread starter macrumors newbie

    Dec 1, 2010
    Thanks all,It is annoying for me a long time.
  8. nephilim7, Jun 19, 2011
    Last edited: Jun 19, 2011

    nephilim7 macrumors regular

    Jun 13, 2008
    I'm sure it's an oversight... on dp3 control up-arrow was linked to mission control with no way to change it (which messed me up in emacs).. in dp4 it's listed in the keybindings so you can change it... but now control a isn't working.

    it will be fixed... but it's a showstopper for an old *nix fart like me. I can't even use control a or e inside of virtual machines running in dp4.. annoying

    edit: that above fix worked, thank you

    edit: this is very odd... the above fix also seems to have fixed safari not scrolling correctly.. this was literally the first thing I did on a fresh install + software update.
  9. timcharper macrumors newbie

    Aug 26, 2008
    Worked for me to

    rm ~/Library/Preferences/com.apple.symbolichotkeys.plist
    ^^^ Worked for me too, thank you!
  10. djrod macrumors 65816


    Sep 16, 2008
    Madrid - Spain
  11. EMAILBEN145 macrumors newbie

    Jun 16, 2011
    rm ~/Library/Preferences/com.apple.symbolichotkeys.plist

    thanks so much for this fix! ctrl+a was my most important keystroke!!!!

Share This Page