dp4 updated by Apple to work on MBP 11

Discussion in 'Mac OS X Lion (10.7)' started by funkyfresh69, Jun 11, 2011.

  1. funkyfresh69 macrumors member

    Joined:
    Mar 25, 2011
    #1
    Apple have released a minor update to DP4 installer.
    I’ve now got it working on my MBP 11.

    To do this I ran the new updated app from a SL partition and selected a clean partition for the installer to use.
    (To get the new app, trash your existing dp4 app and the app store will then let you download the newver version)

    The installer reboots and then runs fine (it didn’t before at all) and most importantly once the install has finished it doesn’t hang on reboot and no manual deletion of the kexts for the Wi-Fi is needed.
     
  2. AdrianK macrumors 68020

    Joined:
    Feb 19, 2011
  3. FNH15 macrumors regular

    Joined:
    Apr 19, 2011
  4. Psilocybin macrumors 6502a

    Psilocybin

    Joined:
    Jan 16, 2011
    Location:
    Ontario, Canada
    #4
    glad it works on a system that doesnt exist haha
     
  5. Chundles macrumors G4

    Chundles

    Joined:
    Jul 4, 2005
    #5
    2011 MacBook Pro.

    Pretty self-explanatory I thought.
     
  6. Atarikid macrumors regular

    Joined:
    May 14, 2011
    #6
    Great to hear it is fixed.
    So, if you download the full DP4 at App Store, you get a working Lion?
     
  7. funkyfresh69 thread starter macrumors member

    Joined:
    Mar 25, 2011
    #7
    I have a 17” MBP ’11

    The build number is 11A480e, original dp4 build number is 11A480b

    I ran the dp4.app from within SL and target a new empty partition. I did try extracting the instalesd.dmg to a USB disk, and the installer boots the system. But then i get some error about the installation failing, straightway.

    So, the only way i could get DP4 to install was to run the app from SL..
     
  8. alexryans, Jun 11, 2011
    Last edited: Jun 11, 2011

    alexryans macrumors member

    Joined:
    Nov 10, 2010
    #8
    Not sure what the crack is here but I've been running the third update to DP2 (build number 11A444d) as I haven't been able to update to DP3 or 4 on my 2011 MBP.

    Now, all of a sudden, there's a FOURTH update to DP2 that's just appeared in my SU panel. Not sure what it does or where it's come from, but I'm just installing it now. Hopefully it'll fix all the problems us 2011 MBP owners have been having and we'll be able to smoothly upgrade to the newer previews.

    Anyone else found this new update to DP2?

    EDIT:
    Installing now - the "Moving items into place" section no longer displays 'less than a minute to go' as it did witht he other DP2 updates when they got stuck. The progress bar is progressing nicely and at a steady pace, rather than hanging for ages. I'm hoping for positive things!

    EDIT 2:
    Well after a smooth install with no waiting around while items are moved into place, it seems like it was all for nothing - gears still stick after booting.

    EDIT 3:
    Looks like the new update is DP3 - it carries the exact same build number as the previously released DP3 build, however, the WiFi issue is still present. I've had to Target Disk into my MBP, remove the IO80211Family.kext and then re-install it after booting.
    The new boot screen is present, as is all the other stuff that was introduced in DP3. Clearly, Apple are now starting to fix things ahead of launch.
     
  9. Atarikid macrumors regular

    Joined:
    May 14, 2011
    #9
    Worth noting:
    This 11A480e has also faster graphics (Quartz) and is now on par with SL.
     
  10. DannySmurf macrumors 6502a

    Joined:
    Jul 7, 2005
    #10
    Is there supposed to be some global issue with the '11 MBPs? I have 11A480b and it's running fine on my 13".
     
  11. Atarikid macrumors regular

    Joined:
    May 14, 2011
    #11
    Not sure but guess not. Mainly the latest MBP 15" and 17" seems to have issues with installing (Wifi problems)
    But I discovered a hugh graphic speed improvement too. So between 11A480b and 11A480e there are other fixes/improvements made.

    The only two things that do not seems to work correct are:
    - My keyboard backlight is always on (no matter what I set in the preferences)
    - The corrupted boot screen

    But I am very very glad the graphics speedup is already fixed! That was a big let down for me.
     
  12. LuMe96 macrumors newbie

    Joined:
    Jun 8, 2011
    #12
    Hi,
    nice to hear they got it working.

    I'm running the 480b version on my MacBook Pro 2011 13" but with the IO80211Family.kext of SL which works but with glitches. As I 'don't really want to go back to SL to completely reinstall Lion only to get that one file, could someone post the IO80211Family.kext of that last version 11a480e please?

    Thanks a lot.
    Bye,
    Lutz
     
  13. funkyfresh69 thread starter macrumors member

    Joined:
    Mar 25, 2011
    #13
    there is a different wi-fi chipset used on some European models (compared with models sold in US). thats why its not apparently affecting all MBP '11 models, and i guess maybe why Apple have been slower to fix the issues..
     
  14. delwynnpawn macrumors newbie

    delwynnpawn

    Joined:
    Jun 12, 2011
    Location:
    Canada
    #14
    Been worried about this for a while now, does anybody know what is causing the glitchy boot up screen? or maybe how to fix it? i'm getting real anxious about that stuff damaging something in my machine... any help would be appreciated thanks! :confused:
     
  15. Atarikid macrumors regular

    Joined:
    May 14, 2011
    #15
    No worries. It will most certainly not damage your hardware. Just some graphic driver glitch.
    On the Apple devs forum it is mentioned several times, so Apple is aware of this.
     
  16. delwynnpawn, Jun 13, 2011
    Last edited: Jun 13, 2011

    delwynnpawn macrumors newbie

    delwynnpawn

    Joined:
    Jun 12, 2011
    Location:
    Canada
    #16
    Well, thanks for your reply. It seems that I have to deal with this till the GM arrives. Enjoying everything except the boot screen though. It's weird cause I never experienced a hang on first reboot during installation nor an issue with the wi-fi, only this screen. And I'm quite sure I encountered it the first the on the first reboot during installation. Thanks again for the help anyways! :)
     
  17. nonamelive macrumors member

    nonamelive

    Joined:
    Aug 7, 2009
    Location:
    San Francisco
    #17
    Could anyone share the new IO80211Family.kext? AirDrop doesn't work since I replaced the file with the one in Snow Leopard.
     
  18. flowsy macrumors regular

    flowsy

    Joined:
    Aug 16, 2009
    Location:
    Germany
    #18
    Don't laugh, but 11a480e also feels snappier on the late 2008 MacBook. :D
     

Share This Page