Draft Mail messages are sent when I click Get Mail

Discussion in 'Mac Basics and Help' started by elefolio2009, Oct 17, 2010.

  1. elefolio2009 macrumors newbie

    Joined:
    Oct 17, 2010
    #1
    How do I turn this feature off? If I have a message in the middle of being composed, and click Get Mail, off the draft message goes whether I'm ready to send this or not. This is an old issue, and generally I just try to remember not to check mail when I have a message in progress. But I can't find a screen anywhere in Mail Prefs to turn this feature off. In other words, I only want mail to send messages when I the Send paper airplane icon, not in response to my checking incoming messages. I'm running OS 10.5.8 and Mail v. 3.6 (936).

    Apologies if this is answered elsewhere. I did look for this on the forums and could not find it.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Just curious, why are you clicking Get Mail in the middle of composing an email? Why not wait until you're finished? When Mail automatically checks for new messages (without clicking anything) during mail composition, it will not send the message being composed.
     
  3. RogersDA macrumors 6502

    Joined:
    Aug 19, 2009
    #3
  4. elefolio2009 thread starter macrumors newbie

    Joined:
    Oct 17, 2010
    #4
    GG, sometimes I am multitasking, and switching between Mail and another application, and out of habit I click Get Mail. I realize not clicking it is the best fix! But I can't believe there isn't a way to turn this off. It seems odd Mail would send a draft message before you hit Send.
     
  5. elefolio2009 thread starter macrumors newbie

    Joined:
    Oct 17, 2010
    #5
    RodgersDA, you mean compose mail before addressing it? Good idea. Still interesting in learning whether it's possible to turn this option off or if it's a glitch.
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    You don't ever have to click Get Mail. Mail > Preferences:
    ScreenCap 9.PNG
     

Share This Page