Drag and Drop on Desktop not working... need fix

Discussion in 'OS X Mountain Lion (10.8)' started by macguy11, Jul 25, 2012.

  1. macguy11 macrumors member

    Mar 19, 2011
    Hey guys,

    When I pick up an item on the desktop, it essentially 'sticks' to my mouse and i can't drop it anywhere. If i click esc, it sometimes goes back to where it was. It seems like a bug but I need a fix for this. It also happens when I'm working inside programs and the cursor just gets stuck on selecting and I can't unclick. Can anyone offer a solution?

  2. steffenkarspeck macrumors newbie

    Jul 26, 2012
    same here

    Same here, need a fix workaround very quick. can't reinstall my whole system.
  3. Michaelgtrusa macrumors 604

    Oct 13, 2008
    In Lion their was this same issue when dragging from the dl folder.
  4. relayer250 macrumors newbie

    Aug 16, 2010
    Saome problem

    I have exact problem since installing 10.8. Never had this happen before. Seems to have same problem in dock and Finder. :(
  5. MrG299 macrumors newbie

    Sep 29, 2008
    Kalamazoo, MI
  6. johnlmccurdy macrumors newbie

    Jul 29, 2012
    this used to happen to me a lot in Lion. Only thing to solve it was turning the computer off and then on again! Annoying - I know...
  7. Arelunde macrumors 6502a


    Jul 6, 2011
    CA Central Coast
    System Preferences > Accessibility > Trackpad options > enable dragging without drag lock.

    At least that's one place to find an option on this.
  8. nyolc8 macrumors regular

    Jul 20, 2012
    If the problem appears, open Terminal and type this:
    killall Finder
  9. PJL500 macrumors regular

    Nov 27, 2011
    Same here. 10.8. 'Have to force quit finder very frequently and other programs too.
  10. zankty macrumors newbie

    Nov 26, 2007
    Same here.

    It seems that putting the mac to sleep shortly solves the problem temporally.

    What I like to know is, if you guys also upgrade from Lion?
    Did any of you do a clean install?
  11. Michaelgtrusa macrumors 604

    Oct 13, 2008
    I did a clean install of lion and still had the issue.
  12. zankty macrumors newbie

    Nov 26, 2007
    So I did some testing and I was able to learn that the problem is the same on all user accounts and it does not happen in Safe Boot.

    After that I called Apple and the 2nd Level Support told me that maybe my
    Adobe, VMWare, ClamXav or LittleSnitch may be the cause.

    Has anyone else one of these or a similar program installed? (i.e. Parallels, any antivirus software)
  13. AfternoonDelete macrumors member


    Dec 30, 2010
    If you mean that you can't drag an item from the desktop to the Finder icon in the Dock, so that you could springload into a folder... you can't do this in Mountain Lion, incredibly. You could do this in Snow Leopard and Lion. AppleCare ran every kind of test and concluded this with me.

    A workaround is to drag your home folder from Finder into the Dock, and drag desktop items into that

    It's a truly bad ML regression, forcing users to do this clunky action. I've complained to Apple via Feedback. I hope others do the same. It could result in a return to the better drag- and-drop directly into the Finder dock icon.
  14. dawso1ba macrumors newbie

    Jul 2, 2010
    Had same problem

    I had this same issue after upgrading to mountain lion. I found that it is usually caused by third party software being installed. I had Airparrot, splashtop, and iteleport. Something in there is not compatible. Bad news though, after uninstalling all of that software there must have still been a driver left behind because it did not solve the issue. Ultimately I had to do a clean install of mountain lion and you can't restore from TM, has to be CLEAN install. Good luck look into any of those programs you may have or had. There are a couple others that will do it as well but can't remember the name of them.
  15. zankty macrumors newbie

    Nov 26, 2007
    I figured out the problem on my Mac. It was the Airparrot Audio driver.
    After I did a Erase and Install, migrated my user folder back everything was working.
    After installing Airparrot's Audio driver the problems started again. So I found this solution:
    found it here: http://theotcspace.com/2012/03/11/airparrot-bug-warning/
  16. Michaelgtrusa macrumors 604

    Oct 13, 2008
    Their may be other issues as well.
  17. mckemper macrumors newbie

    Jun 11, 2008
    San Franicsco
    Air Display disabling drag and drop

    I had just installed Air Display when everything I tried to drag was sticking to my cursor. Luckily, I was able to uninstall Air Display and all's well.
  18. Icy1007 macrumors 65816


    Feb 26, 2011
    Cleveland, OH
  19. Burkut macrumors newbie

    Aug 22, 2012
    Tryied and Working

    If you are using Air Display , Uninstall Air Display and it will work.
    uninstaling also solve my launchpad search area typing problem.
  20. Fredvs79 macrumors newbie

    Feb 24, 2012
    Thank you, this helped me. I figure with Airplay built in to ML, I'm not missing anything without AirParrot any more.
  21. crossifixio macrumors regular


    Mar 21, 2007

    Deleting AirParrotDriver.kext & APExtFramebuffer.kext fixed it for me!! I used Easyfind to look for them and then delete them! Glad its over now!
  22. johnnyi macrumors regular

    Oct 16, 2007
  23. magooemp macrumors newbie

    Apr 30, 2010
  24. YaGaYaW macrumors newbie


    Nov 4, 2012
    Uninstalling Air Display did it for me

    I love this forum
  25. pdwalker macrumors newbie

    Dec 23, 2010
    I had the same problem with drag & drop

    I had recently installed air display and things were working

    After my next reboot, the problem showed up.

    Uninstalling Air Display solved the problem.

    Thanks guys!

Share This Page