Dragging items to trash automatically deletes them.

Discussion in 'iMac' started by SeanZy, Sep 30, 2010.

  1. SeanZy macrumors 6502a

    Joined:
    Dec 29, 2008
    #1
    So I have the strangest problem, but when I drag the item to my trash or try to delete an item, it just asks if I want to delete it completely instead of just going to the trash.

    I have tried searching all over, and all I could find was that it does that with files from an external hard drive, but these files are on my macintosh HD.

    Does anyone have a fix for this? It's bugging me! Haha I know I am weird.
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Are you holding down a key while dragging?
    Have you restarted or repaired permissions yet?
    Since when does the issue occur?
     
  3. symbology macrumors regular

    Joined:
    Aug 4, 2010
    #3
    Your .trashes could be corrupt or having issues. A way to get this enabled is to create an alternate .trashses file which causes the system to auto delete files as it cannot write to the .trashes file.
     
  4. iLikeMySelf macrumors member

    Joined:
    Apr 4, 2010
    #4
    Are the files that you are deleting large? It could be that the file is too big to be stored on the trash so it is directly deleted, it happens in windows, in Mac I am not sure but It happened to me today.
     
  5. SeanZy thread starter macrumors 6502a

    Joined:
    Dec 29, 2008
    #5
    This has been happening for maybe a month now?

    But no I dont hold any keys down when I delete them... and no they are not too large for the trash can. A word document gives me the same deal.

    And where can I change or repair permissions for the trash?
     
  6. DLary macrumors member

    Joined:
    Oct 21, 2005
    #6
    I had the same problem and so have several others I know. There appears to be an ownership bug going around. Select get info on your home folder, look at the bottom where the sharing and permissions tab is. If you see a "unknown user", this is probably your problem. You need to correct the ownership of your home folder. Follow the instructions shown here

    http://http://www.youtube.com/watch?v=HBk7fP9TIz4

    This worked for me
     

Share This Page