Dreamboard Woes

Discussion in 'Jailbreaks and iOS Hacks' started by Dhelsdon, Sep 22, 2011.

  1. Dhelsdon macrumors 65816

    Dhelsdon

    Joined:
    Feb 5, 2010
    Location:
    Canadian Eh!
    #1
    Hi,

    So I jail broke my friend's phone for him awhile back and yesterday he phones me up from a random number and tells me his phone is ********d. From the point of powering on, it would boot to lock screen and you could unlock then it'd freeze at the home screen. I told him to reset, nothing -- same issue.

    After a few minutes of troubleshooting over the phone, I finally said to drop it off. He brings it to me, I plug it into my mbp to see if it would be recognized. iTunes see's it, that's a start. I opened up TU in hopes to save his shah blobs (4.3.3) and it only saves 4.3.5 (no surprise there..) so now i am going okay.. what are my options, I can't restore, reboot doesn't work and I can't ssh into the phone because it won't stay powered long enough to connect to my network.

    I started researching, I knew he recently installed Dreamboard so I assumed that was the culprit. I found a thread somewhere with a few suggestions, which mostly failed for me. One was to force SBsettings to boot in safe mode, too bad my buddy didn't use SBsettings. Next was an ssh method of injecting a .dat file into mobile substrate's preferences (which I couldn't do). My last life line of connection was a saviour.

    iPhone explorer, I started by creating the file 'com.saurik.mobilesubstrate.dat'
    I then dropped the file into '/var/mobile/Library/Preferences/' which is where many .plist and .dylib files reside (not sure what everything is for) but then I ejected the phone, and rebooted.. nothing.

    At this point I was lost, I didn't know what else to do. I thought I'd reboot one last time, boom.. it worked!

    I was into safe mode, right away I hopped on cydia and removed dream board and anything related. Resprung and everything was perfect! All this costed me about 2 hours of frustration so I wanted to share my knowledge with MR in case anyone else has any problems. This is not a post demanding for everyone to toss dream board, because I know it works great for some people. It just a story of a issue that few experienced.

    Personally I am going to hold off using dream board until the next couple updates are out. This way the bugs can be sorted out, anyone else had similar issues with Dreamboard, if so how did you resolve it?
     
  2. TheNewDude macrumors 6502a

    Joined:
    Mar 17, 2010
    #2
    That's weird. I've been using Dreamboard for a few days now and haven't had any problems. But I will sure be more cautious now. Maybe avoid using it till a few more updates come out.

    Thanks for the headsup and a result of your efforts!
     
  3. King Bowser macrumors regular

    Joined:
    Aug 2, 2010
    #3
    I can guess what happened to your friend.

    When I installed dreamboard yesterday , I played around with every setting as i usually do. I tried to change a widget to google and the exact same thing that happened to your friend happened to me. It went on this endless cycle of turning on and off. I have sbs so when it would turn on I would slide the top and tried to do safe mode but it wouldn't give me enough ttime to do it before it would restart itself. I caught on and after 40 minutes timed it right to where I did it right. I deleted it and everything works fine now. I even installed the OS7 theme to dreamboard and everything is awesome. Thanks for the thread.
     
  4. Dhelsdon thread starter macrumors 65816

    Dhelsdon

    Joined:
    Feb 5, 2010
    Location:
    Canadian Eh!
    #4
    No problem, I didn't want others to suffer as I had or at least minimize the time spent fixing the issue.
     
  5. brayhite macrumors 6502a

    Joined:
    Jun 21, 2010
    Location:
    N. Kentucky
    #5
    So the Google widget is the culprit, eh? I too had that issue. I was messing with the settings and wanted to see what the Google widget did on the Endroid theme, and it instantly crashes. No touch response. No sleep button response. The only way to do anything to the phone was holding the sleep and home button to reset it. I would reset and it would sometimes let me unlock the phone (still on the Endroid theme), sometimes it wouldn't. When it did let me unlock the phone (touch worked fine on the lock screen), it would crash again and stay frozen on the home screen.

    After rebooting the phone several times repeating this, I plugged the phone into my MBP and iPhone Explorer'd into it and deleted the Dreamboard folder from the Root folder. Rebooted the phone, and the "Runtime error - info.plist is not found" thing came up. Fortunately, that was it though. Everything else loaded fine, back to the original tweaks and setting from the jailbreak, and everything has been working fine since.

    Hope this too can help anyone who ran into my problem. I'm hesitant to reinstall Dreamboard, as neat and cool as it is, only to have this happen to me when I'm away from my computer and can't do anything to fix it.
     
  6. Stinkycat, Nov 16, 2011
    Last edited: Nov 16, 2011

    Stinkycat macrumors newbie

    Joined:
    Nov 16, 2011
    #6
    This is ridiculous!! The google web widget freeze happened to me as well, and I'm really stressed bout it, cuz i can't time it perfectly to get into safe mode...
    Plus, i wanted to know what happens after the error "Runtime error - info.plist is not found"... does it go back to the normal "board" with all the stuff u had since after the dreamboard issue?
    thks!


    EDIT: well.. I just couldn't wait for your response, so I did exactly like u: iExplorer'd while it was frozen and moved the Dreamboard folder to my mac. The iPod is perfect without the dreamboard. What I can do now is delete de endroid folder and move it back to the iPod :) (a little more help for anyone like me)
    Thks King Bowser
     
  7. MrMason007 macrumors newbie

    Joined:
    Mar 24, 2013
    #7
    This happens when you are running a dreamboard theme and the delete dreamboard or the theme... Once you reboot this will happen and i fixed it like this!

    Step 1: Boot up if you are on 6.0-6.1.1 with the volume up button held down. This will start your phone in a kind of safe mode...

    Step 2: Make sure Dreamboard is deleted and reboot!

    This should start up your phone with no problem!!!
     
  8. BumpyFlatline macrumors 68030

    BumpyFlatline

    Joined:
    Apr 11, 2012
    #8
    FYI, this isn't a feature specific to iOS6. It came out during iOS5 and therefore works on iOS5 and iOS6. I'm not sure about older firmwares since I don't have any old devices any more since I sold them but its possible they work too. Just letting you and anyone else who reads this know that its not specific to iOS6.

    I'm mainly making sure people still on iOS5 know they can hold volume up to enter safe mode. :D

    Thanks for posting your Dreamboard fix though. It's always good to post information here so people can have a way to search for it when they have similar problems.
     

Share This Page