Drive is disappearing when FCPX opens

Discussion in 'Digital Video' started by hitek79, Aug 15, 2012.

  1. hitek79 macrumors member

    Joined:
    Feb 11, 2011
    #1
    UGH!!! I really like how easy it's been to learn to use FCPX, but I've had some pretty major problems arise. First was I had some corrupted project, so I had to redo those, and now the program isn't seeing on of my drives at all, and of course it's the drive with EVERY project on it. When I open FCPX, I can see the drive and projects, and then boom, the all disappear. Anyone have any ideas?

    Here's a video of what happens.

    http://www.youtube.com/watch?v=JNZSky0M6kQ&feature=youtu.be
     
  2. mBox macrumors 68020

    Joined:
    Jun 26, 2002
    #2
    Do you have another drive you can move some of the Events/Projects into?
    Do you have another computer with FCPX installed to test your drive?
    Does your drive dismount when you run FCPX?
    It is a strange one.
    At times its a permission error too.
     
  3. hitek79 thread starter macrumors member

    Joined:
    Feb 11, 2011
    #3
    I'll have to dig up an old drive I guess. This is in a MacPro, so it's an internal drive right now. Everything works perfectly on the drive. Works fine for Lightroom, Aperture, and Photoshop. Blah.
     
  4. mBox macrumors 68020

    Joined:
    Jun 26, 2002
    #4
    Can you do a perm check in Disk Utility?
    The fact that the whole Event/Project disappears makes me think that.
     
  5. rseredyn macrumors newbie

    Joined:
    Aug 26, 2011
    #5

    I had similar situation cased by saving the source data with the whole data structure from camcorder on the same disc with Final Cut Projects and Final Cut Events. The disc started then to be idendified as camera and all the Projects and Events disappeared.

    Is it your case?

    Best regards

    Rafal
     
  6. letscopro macrumors newbie

    Joined:
    Jun 18, 2012
    Location:
    Vancouver, BC
    #6
    I had the same thing suddenly happen to me. I reformatted the drive and did a restore from Time Machine. Everything was back to normal after that.

    I don't know if this is the only solution, but it worked for me.
     
  7. mwilloam macrumors newbie

    Joined:
    Apr 3, 2010
    #7
    I'm assuming this was on a second, non OS, hard drive dedicated to files?

    Think I had the same issue and this is what solved it. On some forum post I read that FCP X was having an issue mounting a drive with .mov files (or something) in the /root (or same root as events). The solution was simple. On the disappearing drive create a folder and call it whatever "Everything or Files" and put all of the folders/files on the drive into it so the root of the hard drive is just /"thisFolder". Then save your final cut projects either to the root or create another folder at the root called "FCP Stuff" and save it there. That solved it for me. If it doesn't you can always just drag everything back out of the "thisFolder" back to the root but try that 1st.

    Let us know if it works.
     
  8. hitek79 thread starter macrumors member

    Joined:
    Feb 11, 2011
    #8
    Thanks for all the tips here. Unfortunately I'm not going to be back on at my Mac Pro for like a month now, so I'll have to fiddle with it at that point.
     

Share This Page