Drop in 3D performance in Yosemite (Mac Mini 2012)

Discussion in 'OS X Yosemite (10.10)' started by Oujmik, Nov 4, 2014.

  1. Oujmik macrumors member

    Joined:
    Oct 23, 2012
    #1
    Hi all, has anyone else experienced a drop in game performance since installing 10.10? Particularly on HD4000 equipped machines such as my Mini? I'm only an occasional gamer, mostly SC2 and CSGO, both these games ran fine on Mavericks on Mid to Low settings but now they are stuttering - the FPS just fluctuates wildly so the motions goes smooth then jerky. The weird thing is that it doesn't seem to be a wholesale drop in performance, as it doesn't get worse as more units appear on screen, it's just constant. I've found a few posts dotted around the internet on this issue, but it's hard to tell if it's widespread because most mini gamers run bootcamp so are unaffected.

    Is there a rigorous 3D benchmark I could run to get some comparisons with others on here?
     
  2. Asclepio macrumors 6502a

    Asclepio

    Joined:
    Jul 11, 2011
    #2
  3. drew627 macrumors regular

    Joined:
    Jun 26, 2013
    #3
    Aero effect? Are you sure you're using Yosemite not Windows..
     
  4. Asclepio macrumors 6502a

    Asclepio

    Joined:
    Jul 11, 2011
    #4
    come on!
     
  5. Oujmik thread starter macrumors member

    Joined:
    Oct 23, 2012
    #5
    Okay, I've got a Cinebench R15 score of 18.45 for OpenGL. Anyone with HD4000 care to give me a comparison? I'm running the 2.6GHz quad i7 with 8GB RAM. To be honest I didn't really see any of the stuttering during the test so I'm not sure it reproduced the issue.

    My CPU benchmark on Cinebench was 590 which exactly matched a reference system with the same CPU but discrete graphics and 10.8.5. Unfortunately there were no reference systems with my CPU/GPU combo.
     
  6. Oujmik thread starter macrumors member

    Joined:
    Oct 23, 2012
    #6
    Well, just in case anyone is interested, here are some things I tried, largely without success, but I did find a kind of workaround that should work in games which use the same engine as CSGO.

    1) Renice the process using atMonitor or the terminal (no effect for me, but some have had success)
    2) Disable BeamSync using QuartzDebug (again nothing for me, but some other report an increase in FPS.

    3) Not really a fix, but makes CSGO more playable... turn on 'Laptop Power Saving' in the video options. This is the same as setting fps max 59 from the game terminal. I was seeing my FPS vary every second or two from 100+ down to 10-20, now I get a steady 59. If you have a better GPU but still see this problem, you could try fps max 100 in the terminal for smoother performance.
     
  7. VanillaCrackerC macrumors newbie

    Joined:
    Jun 8, 2013
    #7
    MM 2012 i5
     

    Attached Files:

  8. iPersian macrumors regular

    Joined:
    Oct 23, 2012
    Location:
    Copenhagen, Denmark
  9. Oujmik thread starter macrumors member

    Joined:
    Oct 23, 2012
    #9
    Thanks, at least I'm beating someone! I wonder what made the difference since we both have HD4000.
     
  10. Oujmik thread starter macrumors member

    Joined:
    Oct 23, 2012
    #10
    OK, a further update. The issue definitely seems to be connected with the FPS being unstable. I did some research into frame rate capping in Starcraft 2 and found that you can add the lines

    frameratecap=30
    frameratecapglue=30

    To the file variables.txt.

    As in CSGO this fixed my problem. Motion now appears smooth and the FPS is stabilised. Not sure what Apple have done to the HD4000 drivers for Yosemite but frame rate capping seems to be the workaround.
     

Share This Page