Dropbox

Discussion in 'Mac Apps and Mac App Store' started by davidoloan, May 8, 2013.

  1. davidoloan macrumors 6502

    Joined:
    Apr 28, 2009
    #1
    I'm moving my documents, music, pictures and videos from Ubuntu to Mac.

    I like to use dropbox and on the old computer I had the path for documents as : Home/Dropbox/Documents. I did the same for music, pictures, videos e.g. Home/Dropbox/Pictures.

    I can then save directly to Documents or Pictures and it will go directly to that Dropbox folder which I can then access easily on IOS. This means that when I click on the OS folder link for Documents I actually get my Dropbox documents and Home/Documents no longer exists.

    Can anyone tell me how to do this on the Mac? So far I can only get the Dropbox folder into the Home Folder.
     
  2. numlock macrumors 68000

    Joined:
    Mar 13, 2006
    #2
    not sure if its possible or advised to delete those folders (music, documents, photos etc) but you can symlink them to the dropbox folder

    or am i misunderstanding you?
     
  3. davidoloan thread starter macrumors 6502

    Joined:
    Apr 28, 2009
    #3
    Thanks. I might not have communicated it very clearly. I don't want to delete these folders. But I want to change their location, so that they are in the dropbox folder and the OS X links on the LHS in Finder follow the path Home/Dropbox/Documents instead of Home/Documents.

    I have been using it this way in Linux for several years with no problems. I shouldn't have said Home/Documents would no longer exist; its more that the path is altered.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    What you want is a symbolic link from the "real" folder to Dropbox with the command below in Terminal. After you run this the regular Documents folder in your user space will still be there and you will want to put your documents there... but they will be sym linked to a Documents folder in the Dropbox folder.

    Paste this command in Terminal and hit enter. Then look in your Dropbox folder and you will a see new Documents folder with the little arrow alias arrow on it. If you double click that folder you will see it takes you back to the main Documents folder in your user space.

    Just be aware this will sync the entire contents of your Documents folder to Dropbox. I have mine setup this way so I can see all my Documents folder in the Dropbox iOS app.

    You can repeat this with other folders if you like by just changed the path as needed. One warning though... Dropbox has some warnings in their forums about trying to sync an iPhoto library, so I would not do this with the ~/Pictures folder.

    Code:
    ln -s ~/Documents ~/Dropbox/Documents
    If these Terminal commands scare you, you can use the app MacDropAny to accomplish the same thing. But all it is doing is running the Terminal commands for you.
     
  5. davidoloan thread starter macrumors 6502

    Joined:
    Apr 28, 2009
    #5
    Thank You Weaselboy for all that info and the command. I will try and get it working.

    Thanks also numlock.
     
  6. davidoloan thread starter macrumors 6502

    Joined:
    Apr 28, 2009
    #6
    This command from Weaselboy : ln -s ~/Documents ~/Dropbox/Documents worked perfectly for me in Mountain Lion.

    In Mavericks I get "command not found"

    Anybody know what command I should use?
     
  7. dmorack macrumors newbie

    dmorack

    Joined:
    Feb 18, 2010
    #7
    Try /bin/ln -s ~/Documents ~/Dropbox/Documents

    Maybe your path is not set?

    -D.
     
  8. davidoloan thread starter macrumors 6502

    Joined:
    Apr 28, 2009
    #8
    Thank you, but I get command not found.

    Both commands however put a documents folder in Dropbox (even though Terminal says "Command not found") but it does not make a copy of the documents. It is 28 kb and remains that size.
     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #9
    If you just type the ln command in Terminal do you get the usage suggestions like in my screenshot below?

    There is nothing I can see about the command or its operation that has changed in Mavericks. :confused:

    [​IMG]
     
  10. Madmic23 macrumors 6502a

    Joined:
    Apr 21, 2004
  11. davidoloan thread starter macrumors 6502

    Joined:
    Apr 28, 2009
    #11
    Lots of space left.

    ----------

    Thanks Weaselboy,

    My result was exactly as your screenshot.

    However, I got it to work this evening. Terminal still says "command not found" but it worked properly. The file in the Dropbox folder is still tiny so that had nothing to do with it, but I can now see the contents in the iPad app.

    There does seem to be some glitch. I don't know why it suggests the command is wrong and wouldn't work at first, but at least it is working.

    Thanks to dmorack, Weaselboy and Madmic23.
     

Share This Page