Dropped 13" unibody Macbook pro, hard drive problems!

Discussion in 'MacBook Pro' started by willber, Jan 3, 2012.

  1. willber macrumors member

    Joined:
    Apr 7, 2010
    #1
    Last Friday I dropped my 13" late 2009 macbook pro from 2/3 ft onto wooden floor, it landed first on the side of the hard drive.
    It worked fine for a few hours, until it froze with the beachball and I had to force shutdown. Upon startup I had a flashing folder with a question mark inside, and I tried booting from the snow leopard disc but the drive could not be found in disk utility. Everything I researched pointed to the hard drive being dead, so today I went out and purchased a replacement hard drive and installed it.

    Upon startup I had the same flashing folder icon, but then booted while holding the C key with the snow leopard disc and the drive now shows up in disk utility, but when trying to create a partition or format the drive I get the error 'Disk Erase Failed. POSIX reports: The operation couldn't be completed. Cannot allocate memory'

    Is my old hard drive still likely to be dead or could this be a different problem?

    Thanks!
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
    Sounds like a head crash to me. Funny the motion sensor didn't park it. Fairly easy to replace the HDD, might be an opportunity to look at an SSD (and you can disable the motion sensor for those)
     
  3. willber thread starter macrumors member

    Joined:
    Apr 7, 2010
    #3
    Thanks for the reply. This is what I thought, and so today purchased a new hard drive and installed it but am getting an error when formatting it through disk utility. The os x set up disc will not show the new drive as an install option, but it does show up in disk utility but I am unable to format it or create a partition.
     
  4. willber thread starter macrumors member

    Joined:
    Apr 7, 2010
  5. johnhurley macrumors 6502a

    johnhurley

    Joined:
    Aug 29, 2011
    #5
    Can you use the replacement hard drive when not inside your machine ( like from an external hard drive caddy perhaps )?

    Could be something else damaged besides your hard drive when you dropped it.

    Sounds like time to take it into apple or an authorized service center and get it diagnosed.
     
  6. merrickdrfc macrumors 6502

    Joined:
    Jan 8, 2011
    Location:
    Manchester
    #6
    Ensure that the partition scheme is GUID instead of MBR (Disk Utility/Select Disk/ Partition/ 1 Partition/ Options) and that the drive is formatted in Mac OS Extended (Journaled)
     
  7. willber thread starter macrumors member

    Joined:
    Apr 7, 2010
    #7
    Thanks for the advice everyone. Took it to my local Apple store yesterday and it was the ribbon cable after all, my old hard drive is fine so no data is lost! And they replaced it for free! All back to normal now but I have 1tb internal instead of 160gb..bit of an upgrade haha
     
  8. Blondie :) macrumors 6502a

    Blondie :)

    Joined:
    May 12, 2010
    Location:
    Prescott, AZ
    #8
    I had this issue with my first MacBook when I was younger and playing around with different OS's and such. When I went back to using only SL, I couldn't initially select my hard drive as the install location. I had to format the disk AGAIN using disk utility. So essentially, even though the disk might be new, you have to format it again for some reason. At least it worked for me, as after this I was able to install my copy of SL from the disk.

    ----------

    Additionally, I don't know if you can do this or not, but if initially erasing the disk doesn't work, try to verify the permissions first (if you can)
     

Share This Page