dropped 3gs mystery

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Grassy7, Mar 13, 2011.

  1. Grassy7 macrumors newbie

    Joined:
    Mar 13, 2011
    #1
    Search all over the web for a resolution, but have only come up with half knowledge of how to jailbreak which is really NOT what I'm looking for. Here's the deal:

    My sistere's 3gs was dropped hard enough to bend the silver frame near the volume. Won't power up at all even after an all night charge. Opened it up and discovered a broken mute switch bracket. Thought maybe the headphone jack flex cable assembly was damaged too. Ordered new bracket and assembly. Assembly came in first and is temporarily installed (just a few screws to hold it down until bracket comes). Phone still won't power up. iTunes recognizes in DFU mode. Click on "Restore and Update" and continually receive errors 1600, 1601, 1604, 2009, 3194 (not at the same time). After hours of searching for fixes on web, have downloaded iREB, tinyumbrella, snowbreeze, and redsnow. I do NOT want to jailbreak, but have read that these programs can prepare the phone to receive custom firmware through iTunes recovery. None of these programs have worked yet. Not sure if I have the right combination. I think that the phone was running iOS 4.2.1 (because 4.3 has recently come out while this phone has been down). I even tried downloading 4.2.1, then went into "edit hosts" through "cmd" (winXP), then used tinyumbrella to "trick" iTunes into accepting an old iOS to restore to the phone....no luck.

    Think I need the right combination here. I've tried the whole start iTunes, get the phone in DFU, close iTunes, open iREB, select "3gs", let it go through that process, restart iTunes, then tried restoring both 4.2.1 and 4.3 at different attempts. I've looked everywhere for resolutions. I know that the problem is the firmware. Not sure if it's a hardware failure of the motherboard. The screen and battery work (i've tested them using my iphone 3gs). Hope I've given enough clues here....help anyone???
     
  2. Crystal-RX macrumors 68030

    Crystal-RX

    Joined:
    Dec 22, 2008
    Location:
    Seattle, WA USA
    #2
    Was your sister phone jail broken and unlocked before it was dropped?
     
  3. Grassy7 thread starter macrumors newbie

    Joined:
    Mar 13, 2011
    #3
    Neither jailbroken nor unlocked. Every forum I read that had anything to do with solving the error codes that I mentioned pointed to using those programs that were designed for jailbreak. There wasn't much on the apple website. 1602 and higher are listed but not 1600 & 1601. I tried rebooting the computer over and over. I tried using all of my computer's USB ports front and back. I used different iphone/ipod usb cables. It almost seems like the bootrom or something is corrupt or missing...just guessing. I read something about knowing what the ECID is on the phone and fixing that...no idea.
     
  4. solientblack macrumors newbie

    Joined:
    Apr 26, 2011
    #4
    not even sure if you still check this thread, did you happen to find a fix? I just dropped my 3GS last night and I am getting the same problems you are.
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    Sounds like hardware issue cause of the drop.
     

Share This Page