Dropped iBook G4 (no damage), Now Kernel Panics

Discussion in 'PowerPC Macs' started by Geoff Myers, Jan 17, 2009.

  1. Geoff Myers macrumors member

    Joined:
    Mar 19, 2007
    #1
    I recently dropped my 4 year old iBook G4 (while it was sleeping) onto a wood table from about a foot up. When I tried restarting it, I kept getting kernel panics. So I completely reinstalled the OS (Leopard). Now I can do most tasks on the computer, but I still get kernel panics on a regular basis. I think there is clearly a hardware issue, although there is apparently NO physical damage to the machine. There is nothing wrong with the hard drive, which is the only mechanical device that could possibly be damaged by a drop, right? Reinstalling Leopard didn't really solve the problem. (I'm looking for an Apple Hardware Test disc to see if that will help diagnose the problem...)

    Any words of advice? Suggestions would be greatly appreciated. Thank you! :)

    Here are the details for the kernel panic (after I reinstalled 10.5 -- I haven't updated to 10.5.6 yet):

    Sat Jan 17 10:06:16 2009
    panic(cpu 0 caller 0x000AE584): "Uncorrectable machine check: pc = 00000000319D0E88, msr = 0000000000149030, dsisr = 42000000, dar = 00000000067E0000\n" " AsyncSrc = 0000000000000000, CoreFIR = 0000000000000000\n" " L2FIR = 0000000000000000, BusFir = 000000000000ff00\n"@/SourceCache/xnu/xnu-1228/osfmk/ppc/trap.c:975
    Latest stack backtrace for cpu 0:
    Backtrace:
    0x0009AD18 0x0009B6BC 0x00029DC4 0x000AE584 0x000AE804 0x000B22F8
    Proceeding back via exception chain:
    Exception state (sv=0x30a6d500)
    PC=0x319D0E88; MSR=0x00149030; DAR=0x067E0000; DSISR=0x42000000; LR=0x319D0F70; R1=0x305CFBA0; XCP=0x00000008 (0x200 - Machine check)
    Backtrace:
    0x00000000 0x31A29B18 0x31A2A484 0x319CA3D0 0x00355B40 0x003547BC
    0x00354E58 0x000AFE54
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.driver.AirPortBrcm43xx(302.25.10)@0x319c0000->0x31aecfff
    dependency: com.apple.iokit.IO80211Family(200.7)@0x300ee000
    dependency: com.apple.iokit.IOPCIFamily(2.4)@0x29e84000
    dependency: com.apple.iokit.IONetworkingFamily(1.6.0)@0x3000b000
    Exception state (sv=0x29d94500)
    PC=0x00000000; MSR=0x0000D030; DAR=0x00000000; DSISR=0x00000000; LR=0x00000000; R1=0x00000000; XCP=0x00000000 (Unknown)

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    9A581

    Kernel version:
    Darwin Kernel Version 9.0.0: Tue Oct 9 21:37:58 PDT 2007; root:xnu-1228~1/RELEASE_PPC
     
  2. cantthinkofone macrumors 65816

    cantthinkofone

    Joined:
    Jul 25, 2004
    Location:
    Missouri, USA
    #2
    try re-seating the ram. might have been knocked loose during the fall.
     
  3. iSee macrumors 68040

    iSee

    Joined:
    Oct 25, 2004
    #3
    The hardware test disc is a good thing to try because it might help narrow down the problem. The fall knocked something out of whack internally.
    If you are lucky something like reseating the RAM will fix it. A bad thing would be if something's damaged on the logic board.

    Good luck
     
  4. iSee macrumors 68040

    iSee

    Joined:
    Oct 25, 2004
    #4
    The trace you added suggests the problem might be that the airport driver is crashing. Try turning Airport off and see if your computer continues to crash.
    And/or try reseating or removing the Airport card. It's pretty easy to access on these computers (I think).
     
  5. Sun Baked macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #5
    You'll have to hunt around for the airport card, I think Apple was still tucking the little board in tight space miles from the logic board.
     
  6. sahnert macrumors 6502

    Joined:
    Oct 20, 2003
    Location:
    Seattle
    #6
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 2_2 like Mac OS X; en-us) AppleWebKit/525.18.1 (KHTML, like Gecko) Version/3.1.1 Mobile/5G77 Safari/525.20)

    if this is a late iBook G4 the airport card is not easily accessible. However I'll bet that it is what's causing the crash. It can be reseated or replaced but you'll have to open up the whole computer.
     
  7. bizzle macrumors 6502a

    Joined:
    Jun 29, 2008
    #7
    Check hard drive health with SMART utility. Reseat RAM and Airport card. Check logs after kernel panic and see if you see references to specific components. If you do all of the above and the hard drive passes SMART, but issue persists. Remove different components and see if the issue persists. If all persists, boot from external media and see if issue persists.
     

Share This Page