Dropped iPhone 3GS won't read SIM card - please help

Discussion in 'iPhone Tips, Help and Troubleshooting' started by sortapundit, Sep 19, 2009.

  1. sortapundit macrumors newbie

    Joined:
    Sep 19, 2009
    #1
    Hi guys. I hope you can help recover my 3GS - it's been screwed for two months now, and I think I'm starting to lose it.

    This problem has dragged on for a while now, so apologies if I can't remember certain details...

    When I got my 3GS I didn't have the time to get my existing phone number transferred, so rather than mess around with a new number I just inserted my old SIM card from my 3G and packed the new SIM away.

    A week later I drunkenly dropped the 3GS on a cobbled street in the Czech Republic. Two painful bounces later and I had a freshly f*cked phone. The phone was stuck on the screen with a picture of a USB cable and the iTunes logo, with the message "Restore needed. iPhone cannot make or receive calls" etc. etc. Both the IMEI and ICCID are unknown.

    When I tried to restore the phone iTunes wouldn't play ball, displaying the message "iTunes cannot activate your iphone because the sim card is not inserted or a sim pin is required". I don't use a SIM pin and the SIM card was (as far as I can tell with many, many checks) properly seated. However, iTunes successfully transferred my photos from the phone and I managed to rip my music onto my laptop using Xilisoft iPhone Transfer. Apart from the fact that the phone won't shift from the restore needed page it seems in good working order.

    Being a continent away from home and getting further away every day I had no option to visit an Apple Store or return the phone to the retailer for a replacement, so I spent the next two months trying to force restores using DFU and recovery modes to no avail. I was crossing Central Asia at the time so I didn't have much access to the Internet.

    Now, though, I've reached my first stable internet connection in 8,000 miles in Mongolia, so I thought I'd take the opportunity to ask you fine people what you think might be the problem. I've spent the last few days Googling the and I can't find a solution. This morning I found myself so desperate to fix the problem that I disassembled the phone using a razor blade and the suction cup from a travel shaving mirror - not recommended, by the way - but couldn't see any obvious signs of physical damage. All six points on the SIM connector seem fine. Beyond that the innards of a phone are voodoo to me, so I can't say for certain that there wasn't any damage.

    Anyway, it occurred to me today that the problem might be that, when I originally broke the phone, the SIM card I was using wasn't the SIM that came with the phone. I have no idea how these things work, but could it simply be a matter of needing the correct SIM card inserted before a restore will work? If so, is there anything I can do to resolve the issue here in Mongolia? It's gonna be a few more weeks before I return to the UK and I'd love to get it fixed before then, but I wouldn't trust the locals to touch anything of mine - they like to start the day with a good healthy shot of vodka and they don't stop until they pass out after dinner. Drunk shaky hands don't mix with electronics.

    I'd really appreciate any help you can offer, even if the answer is 'it's a hardware problem, you clumsy fool. You're screwed'. I'll try to answer any questions you have.

    p.s. The 3GS had never been jailbroken or fiddled with in any way prior to its meeting with Czech masonry.

    Thanks in advance for your help :)
     
  2. sortapundit thread starter macrumors newbie

    Joined:
    Sep 19, 2009
    #2
    *Update*

    Now I have a decent Internet connection I managed to 'successfully' jailbreak with redsn0w 0.8. The process completed without a hitch, but when the phone boots up it has no service, and both wifi and bluetooth are greyed out in the settings menu and listed as unavailable.

    I attempted to restore the phone through iTunes but it came up with an error 23 mid-restore. Tried to reset the phone back to factory settings and it wiped EVERYTHING - settings menu, ipod, phone and text buttons, the whole lot. Used redsn0w once more, and now I have nothing on the home screen but a few random apps that were stored in the backup on my laptop. Bah.

    Right, I'm off to the least Irish Irish pub in the world to listen to some Mongolian dude sing Lady in Red. What a country.
     
  3. davew22 macrumors newbie

    Joined:
    Aug 20, 2009
    #3
    Failed restores can be caused by having a sim card inserted, have you tried the restore without a sim in.

    Dave
     

Share This Page