Dropping wireless connection problem--FIXED!!

Discussion in 'MacBook' started by inkswamp, May 25, 2008.

  1. inkswamp macrumors 68030

    inkswamp

    Joined:
    Jan 26, 2003
    #1
    Sorry for the over-excited subject line, but after a week of experimentation, I think I've finally figured out what settings to tweak on my iBook to stop the frequent disconnects. I'll explain what I did below and I'd appreciate it if you could post your results here if you try it.

    I'm using a 2004 iBook G4 with Airport Extreme that I bought off eBay two months ago. It was bought to replace an iBook G3 that died. The iBook G3 had an old Airport card and I never experienced this wireless dropping problem with that. When I got the new iBook, it started dropping the connection about every 10-15 minutes.

    Here's what I changed that appears to have fixed it. Go to System Preferences and click on "Network." Under the "Show" menu, select "Network Port Configurations." When I first looked at this, Built-in Ethernet, Built-in Firewire and Internal Modem were all turned on and above Airport in the list. I only use Airport so I turned the other three options off and moved Airport to the top of the list. Click "Apply Now", close the control panel and reboot your machine. After I did that, my connection issues stopped.

    Now, this was a fresh install of OS X so I'm wondering why it defaults to having all these ports turned on. Apparently having them on and above Airport causes this issue. I don't see why it should.

    Again, I would like to request that if you try this, please post your results. I'd like to compare notes with others who try it.

    [EDIT-- as pointed out below, these steps are specific to 10.4.11. I'll post steps for finding the network port config screen for Leopard later today.]
     
  2. Bobioden macrumors 68000

    Bobioden

    Joined:
    Sep 23, 2007
    Location:
    Denver
    #2
    There is no Show menu under the Network settings using Macbook with Leoprard 10.5.2 and a Airport Extreme card.
     
  3. Hawkeye411 macrumors 68000

    Hawkeye411

    Joined:
    Jun 6, 2007
    Location:
    Canada EH!!!
    #3
    I've been having some weird wireless issues. I just checked the Network settings and Parallels-Guest and Parallels NAT were both active. I just turned them off and made sure that AirPort was at the top of the list. I seem to recall that I began having problems after installing Parallels but I wasn't certain.

    I'll let you know if things are back to normal now.

    Cheers.
     
  4. inkswamp thread starter macrumors 68030

    inkswamp

    Joined:
    Jan 26, 2003
    #4
    Sorry. I'm still running 10.4.11. I should have said that. I'm not in front of a Leopard machine so I'm not sure what the specific instructions are for getting to the Network Port Config screen, but I know it's in there somewhere. I'll be at my job later tonight where I use Leopard, and I'll post the steps from there if nobody else does so before then.
     
  5. Hawkeye411 macrumors 68000

    Hawkeye411

    Joined:
    Jun 6, 2007
    Location:
    Canada EH!!!
    #5
    System Preferences
    Network
    The List of Ports is on the left (i.e. AirPort, BlueTooth, etc.)

    --------------------------------------------------
    It's working so far .... Got my fingers crossed.
    :D
     
  6. Hawkeye411 macrumors 68000

    Hawkeye411

    Joined:
    Jun 6, 2007
    Location:
    Canada EH!!!
    #6
    I really hate to get my hopes up but .... it seems to be working fine for the first time in MONTHS.

    I'll post a followup some time tomorrow or the next day.

    Cheers.
     
  7. MacDann macrumors 6502a

    MacDann

    Joined:
    Mar 27, 2007
    Location:
    Can see the end of the Earth from here
    #7
    Looks like in Leopard when you have the Network window open, you can click on the little "gear" at the bottom (heck, I'm sure there's a name for it) and one of the selections is "Select Order".

    I have to look at this on my MBP - I've been having problems with it dropping wireless connections....

    Thanks!

    MacDann
     
  8. inkswamp thread starter macrumors 68030

    inkswamp

    Joined:
    Jan 26, 2003
    #8
    That's what I was like when I first did this, hopeful but not wanting to get too excited about it.

    Anyway, I have my fingers crossed for you. :)
     
  9. shawsinio macrumors regular

    Joined:
    May 29, 2006
    Location:
    UK
    #9
    Maybe it's just a bit of a placebo effect, but my core duo macbook which has always been pretty dodgy with airport connections, seems to be behaving much better this evening too...I don't really see why changing that setting would make that much of a difference though?!:confused:
     
  10. inkswamp thread starter macrumors 68030

    inkswamp

    Joined:
    Jan 26, 2003
    #10
    Definitely not a placebo effect. The first month or so that I had my new iBook, I was losing the connection every 10 minutes. In the last week since I changed those settings, I've lost connection only a few random times--no more than what would have happened back with my previous iBook.

    I'm not sure what's going on with those settings, but changing that definitely improved my computer's ability to stay connected. I don't know what's going on there. Perhaps each of those connections does some kind of periodic check to see if it's connected and something going on then is interfering with Airport. Who knows?
     
  11. Hawkeye411 macrumors 68000

    Hawkeye411

    Joined:
    Jun 6, 2007
    Location:
    Canada EH!!!
    #11
    I knew it was too good to be true :(

    Glad it worked for you though!!

    Cheers.
     
  12. inkswamp thread starter macrumors 68030

    inkswamp

    Joined:
    Jan 26, 2003
    #12
    Interesting. So what happened? It worked for you temporarily after you changed it, but it went back to dropping connections again?
     
  13. Hawkeye411 macrumors 68000

    Hawkeye411

    Joined:
    Jun 6, 2007
    Location:
    Canada EH!!!
    #13
    I fixed my wireless problem tonight. Here is a link to the thread I created with the details.

    Just thought that you might be interested in the issue I was having and the solution.

    Cheers.
    :):apple:
     
  14. inkswamp thread starter macrumors 68030

    inkswamp

    Joined:
    Jan 26, 2003
    #14
    Well, bugger. The problem has come back. :(

    I'm not giving up on it, however. The fact that I managed to get almost a week of reasonable connectivity by making the changes to these settings tells me I'm on the right track. I'll keep experimenting and post here if I see any success with it.
     

Share This Page