.ds_store in trash, can't delete

Discussion in 'macOS' started by emt8q5, May 14, 2008.

  1. emt8q5 macrumors member

    Joined:
    Jul 21, 2007
    #1
    hey folks, recently my life has been ruined by a .ds_store file in my trash. I am at a complete loss here. the file is not there when I look in the trash folder, however if I "command-a" I see a weird fild in the trash. If I then copy that file onto my desktop, it turns into a .ds_store file.

    Has anyone run into this? How do I get rid of a .ds_store file in my trash?

    Thanks!
    Eric
     

    Attached Files:

  2. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
  3. bstreiff macrumors regular

    Joined:
    Feb 14, 2008
    Location:
    Austin, TX, USA
    #3
    You could open up Terminal and try to remove it from the command-line... it should be in ~/.Trash.
     
  4. inkswamp macrumors 68030

    inkswamp

    Joined:
    Jan 26, 2003
    #4
    I just logged in to post the same. You should be able to delete it with "rm" or "sudo rm" if you're not logged in on an admin account.
     
  5. TuffLuffJimmy macrumors G3

    TuffLuffJimmy

    Joined:
    Apr 6, 2007
    Location:
    Portland, OR
    #5
    .ds_store's are fine. It's a file that tells the finder how to display that folder. If you delete one it regenerates it. The file exists in every folder, but it's supposed to be invisible. I don't know why you're seeing it in the trash, but it doesn't matter. Every time you delete it it will just come back.
     
  6. emt8q5 thread starter macrumors member

    Joined:
    Jul 21, 2007
    #6
    The problem lies in what happens to the DS_Store file once it is in the trash. If you look at the .png I attached to the original post, you will see what happens when I go to the "empty" trash and do command-a. I select a very odd file name that turns into a DS_store file when copied and pasted from my trash onto my desktop. I understand that .DS_store files are supposed to be in all my folders, I have run into dificulty in that the .DS_Store file is being corrupted when it goes into the trash and as a result, I am never able to empty my trash can.
     
  7. emt8q5 thread starter macrumors member

    Joined:
    Jul 21, 2007
    #7
    Problem solved!

    Just in case anyone on this board has this problem in the future, I found the solution. The file originated from my windows XP bootcamp partition. Running chkdsk solved the problem and my trash can is now emptied.

    I found the solution here:
    http://discussions.apple.com/thread.jspa?messageID=5827887
     

Share This Page