Dual 1.25 GHz PowerPC G4 - Upgrade Compatability

Discussion in 'PowerPC Macs' started by uphype, Oct 20, 2008.

  1. uphype macrumors newbie

    Joined:
    Oct 19, 2008
    #1
    I curently have 10.3.9 with a PowerPC G4 dual w/ 1.25 processors and 2 gig of ram. I want the highest upgrade I can get that will be compatibe with my software which is:

    Quark 6.5
    Acrobat 7.1
    Acrobat Distiller 7.0
    Illustrator CS1
    Photoshop CS1
    AND
    Microsoft Office (don't know what version but I've had it for years)

    I really can't afford to go buy all the software again and I don't want my system to crash. Any suggestions?

    This upgrade is mostly spawned due to the recent purchase of a new iPod Nano... Not supported by my current OS! Man, I didn't read the requirements, shame on me. However, the dang thing will work on my kid's PC w/ XP Pro. I only got the Nano cause it's mac - he wanted the Zune that ONLY works w/ PC... Waa!!

    Anyway - any suggestions on an upgrade?

    Thanks,
    Uphype
     
  2. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #2
    Buy a retail DVD of Leopard 10.5 :D. That is a nice machine. With the 2gb you got, it will fly.
     
  3. SmurfBoxMasta macrumors 65816

    SmurfBoxMasta

    Joined:
    Nov 24, 2005
    Location:
    I'm only really here at night.
    #3


    Agreed....go for it..... NOW :D

    My little ole 1.6ghz/SP/1.5GB QS can run 10.5.5 reasonably well, so I'm certain that your machine will too !
     

Share This Page