Dual-band AirPort Extreme configuration software

Discussion in 'Mac Accessories' started by jzuena, Mar 28, 2010.

  1. jzuena macrumors 6502a

    jzuena

    Joined:
    Feb 21, 2007
    Location:
    Lexington, MA, USA
    #1
    I have a simultaneous dual-band AirPort Extreme base station running software version 7.5 and can't find the software install disk it came with. I reinstalled Snow Leopard onto my mini and it has AirPort Utility 5.4.2. When I try to connect to the AEBS, I get a pop-up stating that a newer version of AirPort Utility is needed, but I can't find anything newer than 5.4.2 on the Apple download site. Does anyone know if Apple has the AirPort Utility software that works with this hardware/software available somewhere?
     
  2. playalistic macrumors regular

    Joined:
    Sep 27, 2007
    Location:
    Surrey, UK
    #2
    No they don't, which is totally dumb on their behalf.
     

Share This Page