Dual display & USB to DVI problems with Snow Leopard

Discussion in 'macOS' started by mgamber, Aug 29, 2009.

  1. mgamber macrumors 6502a

    mgamber

    Joined:
    Jun 12, 2008
    Location:
    1966
    #1
    I got a 24" iMac (2.93 GHz Core 2 Duo variety) about 6 weeks ago and hooked up my Matrox DualHead2Go to find it wouldn't push the two external monitors to their 2x1680x1050 potential. Ok fine, I got an Arkview USB2 to DVI adapter and had one monitor attached to the inferior DVI port, the second connected to the Arkview adapter and both worked at 1680x1050. Today I updated the box to Snow Leopard to find that NEITHER solution works any longer. The Arkview adapter simply disappeared. The computer refuses to see it and the console seems to indicate that it tries to talk to the adapter but gets nothing back. My guess is something changed in the way SL talks to drivers which trashed that solution. Then I tried the Matrox again thinking 2880x900 is still better than 1680x1050 and while it sees the Matrox box and sees it as 2880x900, the second monitor never "lights up". Does anyone know (no guesses or assumptions, please) of anything that actually works with SL that will let me attach the two external monitors?
     
  2. mgamber thread starter macrumors 6502a

    mgamber

    Joined:
    Jun 12, 2008
    Location:
    1966
    #2
    Solution found: The USB to DVI adapter uses a "generic" DisplayLink driver. I went to www.displaylink.com, followed the usual path to driver downloads and grabbed their latest beta which promised to be Snow Leopard compatible. I uninstalled the old one, installed the new one and the third monitor sprang to life. In addition, the old problem of having to unplug the adapter before booting seems to have been corrected, also. I left it plugged it, booted it up and it found and used the adapter and monitor without a problem. Nice! Thanks, me! ;-)
     

Share This Page