Dual monitor/ full screen in VLC

Discussion in 'Mac Pro' started by greedyhands, Aug 3, 2009.

  1. greedyhands macrumors member

    Joined:
    Oct 7, 2008
    Location:
    Atlanta
    #1
    Hi, I know this is a pretty elementary question, but this is my first time using a dual monitor setup. What I would like to do is be able to browse on one monitor while watching video files full screen on another monitor. Is this possible? If so what do I need to do to make it so the smaller monitor doesn't go black once I enter full screen on the larger monitor?

    Thanks in advance.
     
  2. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #2
    You can try using MPlayer OSX, but I think this is a system-wide fullscreen behavior.

    Nothing stopping you from stretching to almost fullscreen though ;)
     
  3. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #3
    Go into VLC's preferences and change it's setup to reflect how you'd like it to react. Don't worry about messing it up, there's a reset all option, though you might need to click on advance first.
     
  4. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #4
    Nope it ain't, the OP's request is possible.
     
  5. geoffreak macrumors 68020

    geoffreak

    Joined:
    Feb 8, 2008
    #5
    I can try it out when I get home to confirm. All I know is iTunes can't do it (unless I have missed the setting) :rolleyes:
     
  6. kellen macrumors 68020

    kellen

    Joined:
    Aug 11, 2006
    Location:
    Seattle, WA
    #6
    In VLC, go to preferences, video playback. Choose one of the monitors for full screen, then take off the selection for black bars.

    Watching a movie now while on the internet, full screen on the second monitor.
     
  7. greedyhands thread starter macrumors member

    Joined:
    Oct 7, 2008
    Location:
    Atlanta
    #7
    thanks kellen

    Thanks a lot kellen, this is exactly what I wanted to do.
     
  8. Arfus macrumors member

    Joined:
    Aug 11, 2010
    #8
    Any wy to hide the dock and finder? Cause when i click on my seoncd mnitor the damn thing at top the menu and the dam ndock is displaying.
     
  9. gugucom macrumors 68020

    gugucom

    Joined:
    May 21, 2009
    Location:
    Munich, Germany
    #9
    This is a question which monitor is seen as the primary monitor by your Mac Pro. Just swap the monitors to get the big screen free for the video.
     
  10. WillSR20 macrumors newbie

    Joined:
    Mar 18, 2011
    #10
    I found this thread while watching alien on a projector and having my MBP screen black out.

    The latest version of VLC has a check box under preferences->video to black all screens or only the full-screen. Just thought I would add an update for others with this issue.
     
  11. tanker5 macrumors member

    Joined:
    Apr 19, 2011
    Location:
    Hoboken
    #11
    Hopefully this will be fixed in 10.9

    Lack of dual monitor full screen app support is one of the biggest complaints about 10.7/10.8 ever since full screen apps were introduced in 10.7. It is widely speculated that 10.9 may address the issue. With WWDC only a few weeks away, hopefully we'll see a fix real soon.
     
  12. Tesselator macrumors 601

    Tesselator

    Joined:
    Jan 9, 2008
    Location:
    Japan
    #12
    What do you mean? How does it currently behave? What's the problem? I ask because I went to a single monitor prior to installing 10.7.x and may yet go back to dual.
     
  13. monkeybagel macrumors 65816

    Joined:
    Jul 24, 2011
    Location:
    United States
    #13
    Most applications, when using the native OS implementation of Full Screen, paints the linen backdrop on the entire secondary monitor rendering it useless for other activities.
     
  14. sarakn macrumors 6502a

    sarakn

    Joined:
    Feb 8, 2013
    #14
    I know it's 4 years later, but this was helpful to me.
     
  15. OrangeSVTguy macrumors 601

    OrangeSVTguy

    Joined:
    Sep 16, 2007
    Location:
    Northeastern Ohio
    #15
    Mavericks should also help now too :)
     
  16. sarakn macrumors 6502a

    sarakn

    Joined:
    Feb 8, 2013
    #16
    I think it was more of a VLC setting with which I was unfamiliar. :)
     
  17. MacUser2525 macrumors 68000

    MacUser2525

    Joined:
    Mar 17, 2007
    Location:
    Canada
    #17
    Nah it messes it up again you need to go into the preferences and deselect the use the native fullscreen mode option.
     
  18. Laz423 macrumors newbie

    Joined:
    Jul 1, 2014
    #18
    VLC with Dual Monitors

    In VLC preferences, turn off "Use the native fullscreen control". Now you will not have the action bar in full screen mode.
     

Share This Page