dual monitor issue

Discussion in 'macOS' started by maigado, Oct 23, 2008.

  1. maigado macrumors member

    Joined:
    Oct 29, 2007
    #1
    I have my MBP running an external monitor. Sometimes, and quite a bit lately, when I close the MBP, but don't turn it off, the second monitor tends to come back on at some point soon afterward. Since the laptop is closed, that causes all the windows on the MBP screen to move to the external monitor. Needless to say, this is annoying on two counts. One is that it happens at all. The other is that I then have to move everything back again.

    Why does this happen and what can I do about it?

    I love my Mac, have become something of a Mac geek, but it gives me at least as much trouble as my Windows machines used to. I wouldn't go back, I use the Mac 95% of the time, maybe more, but anyone who thinks these things "just work" is kidding themselves.
     
  2. pit29 macrumors 6502a

    pit29

    Joined:
    May 23, 2006
    Location:
    The Golden State
    #2
    Do you have an external keyboard or a mouse? If so, and your external monitor switches on upon pressing a key/button, that's actually a feature: it allows to operate your laptop while it's closed...
     
  3. maigado thread starter macrumors member

    Joined:
    Oct 29, 2007
    #3
    Thanks for that. I attached the bluetooth mouse from my Windows machine, since I don't use it much. That's the culprit, I'm sure. My view of this is now different, though I'd like to be able to toggle that feature off. :)
     
  4. chaos86 macrumors 65816

    chaos86

    Joined:
    Sep 11, 2003
    Location:
    127.0.0.1
    #4
    I don't think there's a toggle.

    I think the only good fix is to start using the power button, then clicking sleep, to sleep the machine.

    On the other hand, what happens if you open the notebook after the screen switch has happened? Does it go back to dual screens and the windows go back to where they were?
     
  5. maigado thread starter macrumors member

    Joined:
    Oct 29, 2007
    #5
    When I open the MBP, the MBP screen stays off. I have to open the Displays Pref Pane and tell it to look for all the monitors, which turns the lapdop display on. But all the windows stay in the second monitor. It's a PITA.

    The Sleep tip is probably worth a try. But turning off Bluetooth when I am shutting it down for the night or leaving for awhile will probably take care of it, too.
     
  6. chaos86 macrumors 65816

    chaos86

    Joined:
    Sep 11, 2003
    Location:
    127.0.0.1
    #6
    There's a check box in System Prefs/Keyboard and Mouse/Bluetooth called "Allow Bluetooth devices to wake this computer".

    Try that. I think the problem may be that your bluetooth mouse is pinging the notebook to keep the connection alive, but it accidently wakes it up in the process, and that's when the notebook goes into clamshell mode (running closed).
     
  7. maigado thread starter macrumors member

    Joined:
    Oct 29, 2007
    #7
    Good tip. I looked for this and went right by it. I've unchecked the box and we'll see what happens.

    Thanks.
     
  8. maigado thread starter macrumors member

    Joined:
    Oct 29, 2007
    #8
    That was it, chaos86. Thanks for the pointer.
     

Share This Page