iPhone XS Max Dual Sim and iMessage/FaceTime

TofSanity

macrumors 6502a
Original poster
Oct 29, 2010
663
86
Hello,

I have been using the dual sim since AT&T moved forwarded with it a few months back. Has anyone been able to figure out how to ONLY use one number for iMessages and FaceTime? I have done everything in the settings but the secondary number still shows up in iMessages and FaceTime on my iPad Pro. The secondary number is my work number, so I am trying to keep it separate from my personal equipment.

Thanks
 

simplynando

macrumors 6502
Aug 15, 2016
330
286
Las Vegas, Nevada
Hello,

I have been using the dual sim since AT&T moved forwarded with it a few months back. Has anyone been able to figure out how to ONLY use one number for iMessages and FaceTime? I have done everything in the settings but the secondary number still shows up in iMessages and FaceTime on my iPad Pro. The secondary number is my work number, so I am trying to keep it separate from my personal equipment.

Thanks
I'm pretty sure you can only use one number for iMessage. I have a dual Sim setup on my XS Max. AT&T is my primary using eSIM and Google Fi as the physical secondary sim. iMessage says only one number is allowed to be used for iMessage and all others will be text messages.

Are you talking about wanting to remove the options under the iMessage settings below? Or are you actually getting iMessage/FaceTimes from both numbers?

AB9E35D0-72BB-4DD1-BC98-BD7494E82554.png
 

TofSanity

macrumors 6502a
Original poster
Oct 29, 2010
663
86
What I would like is to not receive any messages on my iPad Pro that aren’t associated with my primary number. I even have everything set to not forward if not an iMessage. I also have my FaceTime setup like this yet I still receive the secondary number’s messages and calls. I looking for a work around if there is one. Thanks
 

simplynando

macrumors 6502
Aug 15, 2016
330
286
Las Vegas, Nevada
What I would like is to not receive any messages on my iPad Pro that aren’t associated with my primary number. I even have everything set to not forward if not an iMessage. I also have my FaceTime setup like this yet I still receive the secondary number’s messages and calls. I looking for a work around if there is one. Thanks
That’s odd. I haven’t had that issue. My iPad doesn’t even show anything at all for my secondary SIM. The “Send & Receive” option under iMessage doesn’t show it either.


4F26AEEF-77D9-4ED9-9C23-0675BF24EEEF.jpeg
 

TofSanity

macrumors 6502a
Original poster
Oct 29, 2010
663
86
That’s what i don’t get. I have everything turned off on my iPad. I don’t even have the secondary number associated with my iCloud account, yet i still receive calls and texts. I wonder if it has to do with how my sims are setup. I have the eSIM as my original primary number and the SIM card setup as my secondary. I no longer have the primary SIM card so i can’t just swap.