(Dual SSD/HDD) Trouble MB Pro

Discussion in 'MacBook Pro' started by rangek1d, Apr 15, 2016.

  1. rangek1d macrumors newbie

    Joined:
    Apr 15, 2016
    #1
    Hey guys first time poster here :)
    I recently got a MB Pro and have been enjoying it until I started to experiment.

    Current Setup: Mid 2012 MB Pro i5, HDD in Caddy and SSD in Main Compartment

    My problems:

    1) I created a fusion drive but could not for the life of me install Windows 10 via Boot Camp (I have tried almost everything listed on forums). During the partitioning phase when you're booted into the windows installer and picking a partition, the "Boot Camp" drive will (out of the 14 times I've tried) never be partitioned the correct way for the machine to go ahead and install windows 10 on there.

    2) As I gave up my hopes on the Fusion drive I thought of just going ahead with having two separate drives. On my SSD (240GB) I portioned and installed Windows 10 via boot camp and everything works perfectly (I am in windows write now typing this up -.-). What I have done now is I am using my SSD for OSX and Windows, yet the HDD in the Caddy is being used as a storage drive (with no OS loaded). The problem arises when I recently noticed that when I boot back and for between OSX and Windows, my HDD storage drive is seeing problems of losing data randomly, erasing itself randomly and the last time that I booted into OSX after coming out of Windows, I got a random message as soon as I got past the lock screen that stated "Blah Blah Blah, One of your drives is not being recognized". I checked disk utility and yet again my HDD had erased itself (losing all the data that I just transferred from my backup).

    I want the HDD to stop erasing itself all the time, that would be nice. Anyway to make that possible? Is there still a way to install Windows 10 on a virtual Fusion Drive?

    Please any help is greatly appreciated.

    Also, how should I format my USB drives so that I can plug them into TV's, OSX and Windows?
     
  2. JTToft macrumors 68040

    Joined:
    Apr 27, 2010
    Location:
    Aarhus, Denmark
    #2
    Sounds like something's wonky with either your HDD or the caddy you're using. Which caddy is it, and which HDD is it?
    And just for good measure, I have to ask if you're sure it's a 2012 machine you're using, and not a 2011?

    - FAT32 is likely the only format that would universally work in all three places.
     
  3. rangek1d thread starter macrumors newbie

    Joined:
    Apr 15, 2016
    #3
    It wasn't any special caddy, just something from eBay. I have made a fusion hard drive now out of the SSD and the HDD and there are no problems at all. Unfortunately I can't do bootcamp on this combined fusion drive either, and I have no idea why. And yes machine is Mid-2012
     

Share This Page