dubious logic board or fan

Discussion in 'MacBook' started by stephenkapple, Jul 28, 2008.

  1. stephenkapple macrumors newbie

    Joined:
    Jul 28, 2008
    #1
    I have a macbook 13.3 " which suffered from water spillage. I have therefore today fitted a new logic board 2.16GHz. My dilemna is that the keyboard does not function (no keys/trackpad) and power button is intermittent - only way to reliably start up is to connect top case connector under power. I will purchase a new top case BUT i also have 2 other faults which i am keen to know if they relate to a faulty logic board.

    * The fans constantly run on full & smc fan controller gives a reading of 1 degrees and 0 rpm.
    * The sleep light is on permanently.

    I have reinstalled OS X & all updates but problems persist.
    All kind assistance gratefully appreciated.
    THANKS
     
  2. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #2
    The keyboard has probably been liquid damaged too - but I guess you have probably worked that out !

    The other problems sound like a bad logic board - where did the logicboard come from ?

    Is the fan the original one ?

    Wa it a Core 2 Duo machine before the liquid damage ?

    Is it working ok from a battery ?

    The sleep light is only normally on until the screen comes on - the fact that it is on constantly again points to a logicboard problem.....
     
  3. stephenkapple thread starter macrumors newbie

    Joined:
    Jul 28, 2008
    #3
    update

    Latest update - i have courtesy of my wifes macbook fitted a known good top case & would you believe it the keys work & power switch is fully functional. Bets of all the fans do not run on full & smc fan control detects fan speed & cpu temp. ONE/TWO problems remain however
    * The sleep light stays on continuously.
    * The computer does not want to install 2 updates - os x 10.5.4 & EFI firmware - you click restart & it gets as far as the install wizard and sems ot stop at about one fifth way.

    Logi cboard was from an ebay seller - original board was core duo 2Ghz and new 2.16Ghz core duo 2 with new heatsikn & battery connector supplied
    ANY IDEAS
     
  4. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #4
    If your original keyboard has the orange ribbon connector and your wife's has a silver then that is probably the reason - core duo 2 keyboards work on Core duo machines but not the other way round - but I think your original keyboard is bad though - replace with a Core Duo 2 one (silver cable).

    Not sure about the updates - are you using the combo 10.5.4 update - if not then download direct from Apple and then run.
     
  5. stephenkapple thread starter macrumors newbie

    Joined:
    Jul 28, 2008
    #5
    many thanks

    for all your excellent advice. i would have never known about the different top cases. I am as we speak reinstalling os x & apple updates with new top case fitted. If sleep light still remains on i will replace hard drive cable and sleep light connector - which i suspect would have been flooded.

    THANK YOU
     
  6. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #6
    Try the hard drive cable but the chances are if the water got into the area of the sleep light you will be stuck with it on the whole time - there is a small circuit around the sleep led but I don't think it is feasible to change it - it is between the metal and plastic parts of the bottom case...

    Best idea would be to change the bottom case if it really annoys you - the bottom case is not that expensive (maybe $30 or so) and a few hours to swap everything over...if you have swapped over a logic board then it will be quicker next time.
     
  7. vniow macrumors G4

    Joined:
    Jul 18, 2002
    Location:
    I accidentally my whole location.
    #7

    Could it be the replacement board has already had the firmware applied?
     
  8. stephenkapple thread starter macrumors newbie

    Joined:
    Jul 28, 2008
    #8
    formware now installed

    After a fresh install of OS X & software update via apples website the emi firmware is now OK - I think the original problem was a break in power mid point through download which corrupted the file. only one problem remains & that is the sleep light - i have seen replacements advertised on ebay - http://cgi.ebay.co.uk/ws/eBayISAPI....m=230271642624&ssPageName=STRK:MEWA:IT&ih=013
    IS THIS PART THE RIGHT ONE????
     
  9. logana macrumors 65816

    logana

    Joined:
    Feb 4, 2006
    Location:
    Scotland
    #9
    Yes that is the part - led on the left and the IR sensor on the right. I have never tried to get that part out but maybe e-mail the seller and ask him if there is a trick to getting the led out and back in again.

    I would love to know the answer too - so if you manage it do tell how it is done. If not them a bottom case replacement is not much more
     

Share This Page