Duplicate Contacts in address book with iCloud

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by Jamooche, Oct 13, 2011.

  1. Jamooche macrumors regular

    Jul 23, 2011
    I upgraded all my software and turned on iCloud on my iPhone and my MacBook Air. When I turn on iCloud in the address book, it duplicates my contacts list. The "On My Mac" Local set of contacts does NOT update and I can't seem to turn off these contacts. The iCloud functions work because when I edit an entry on my phone it updates.

    Is there a way to have only the iCloud contacts visible and updating between my different Macs and iPhone?

  2. vitzr macrumors 68030


    Jul 28, 2011
    I just got a call from work, they are having the same problem. Looks like I'm going to be involved in this before I wanted to. I'd rather take a wait and see approach but now I've got some people that just couldn't wait. If I get it fixed, I will post back.
  3. Jamooche thread starter macrumors regular

    Jul 23, 2011
    Thanks for the info.

    I just tried iCloud out in iCal. That didn't automatically add an iCloud account, so I added one. It doubled up the events in iCal too. When I deleted the added iCloud account in iCal it went back to normal.
  4. Rippeddisc macrumors newbie

    Oct 14, 2011
    add me to the list of wtf...look forward to a solution!

  5. Jamooche thread starter macrumors regular

    Jul 23, 2011
    Thanks for the link, but setting up iCloud is still very complicated. I guess post #9 explains it, but I'm still a bit confused. Will try playing around later.

    I just bought a MacBook Air for my mother 1 week ago and was doing the new updates before she leaves for Florida. (I have yet to do any updates on my machine.) I'm somewhat of a techie computer photography person, but I have no idea how anyone who is a "regular" computer user will be able to setup up the iCloud. It's much too confusing and complicated for the regular user.

    Do you guys agree with this?
  6. E3BK macrumors 68030


    Mar 15, 2008
    If you merge the duplicates, it will sync back to iCloud properly.

    From your iCloud connected Mac: Address Book > Card > Look for Duplicates. Then it will ask if you want to merge them.
  7. Jamooche thread starter macrumors regular

    Jul 23, 2011
    I just tried your suggestion and it says "no duplicates were found" when clearly there are duplicates of all my contacts.
  8. E3BK macrumors 68030


    Mar 15, 2008
    Did you make a backup of the contacts before you migrated to iCloud? You can delete all the contacts in the address book and then import the backup file. If you don't have that....not sure what you can do other than delete them manually.
  9. Rippeddisc macrumors newbie

    Oct 14, 2011
    Ran through it and now only have one group in my contacts called "icloud".

    I'm just pissed at the poor design of address book...need the 3 panel back!
  10. Jamooche thread starter macrumors regular

    Jul 23, 2011
    Yes, I did an export to make a backup of the contacts. I think I did exactly what you said, but I'll try again tomorrow.

    Delete contacts (on laptop and iPhone)
    Turn on iCloud (on laptop and iPhone)
    Import contacts to laptop
    Sync? How does one activate the sync in OSX?

    One attempt earlier tonight it deleted all the iPhone contacts except two seldom used ones. Very strange. The only way I could get it to restore the iPhone was to turn off iCloud and do an iTunes manual sync. I couldn't see any way to since the contacts from the laptop to iCloud and to the phone.
  11. E3BK macrumors 68030


    Mar 15, 2008
    Ah...Try this (at your own risk). This is how I fixed my duplicates.

    Leave iCloud on on your Mac so that iCloud sees the changes.
    Delete the Address Book contacts from your Mac.
    Turn off the contacts on your iphone and delete the contacts.
    Import contacts to Mac address book.
    Turn contacts back on on the iPhone.
    Give it a few minutes and the contacts should sync back on their own.

    Hope this works for you! And hang on to that backup file! Lol.
  12. raulwongroa, Oct 15, 2011
    Last edited: Oct 15, 2011

    raulwongroa macrumors newbie

    Oct 15, 2011
    Here's what worked for me and seems the quickest.

    Go to System Pref on your Mac
    Click iCloud
    Untick Address Book, selected Delete from Mac
    Then tick Address Book again, then select Merge

    Duplicates will be removed and if you are using Birthdays in your Calendar, you'll notice that the Birthday events are back to single entries as well.
  13. leon-geyer macrumors newbie

    Oct 19, 2010
    Thnx, @ raulwongroa :) I before had this solution:
    go in Addressbook to Edit: Distribution List, and unchecked iCloud.
    That made it for me. But I fear this way iCloud wont be actualized (or it will?). Guess your solution is better. Quite a little buggy, the new cat, even in 10.7.2. :D
  14. thebassman78 macrumors newbie

    Oct 15, 2011
    The easiest way I found to fix this, is to simply delete all contacts that you have as local set of contacts, and start only using the iCloud contacts going forward. Here's also a link with this solution to fix duplicate contacts with iCloud.

    Hope it helps!
  15. Ferneaux macrumors newbie


    May 7, 2008

    Worked like a friggin' charm! Thanks @raulwongroa! :) :)
  16. Bob Campbell macrumors newbie

    Oct 18, 2011
    Rio de Janeiro
    Thanks Raul Wongroa

    Your tip and work routine worked well - thanks
  17. michilor68 macrumors newbie

    Dec 14, 2010
    Thanks! That did it for me.
  18. Jamooche thread starter macrumors regular

    Jul 23, 2011
    X2!!! Thanks everyone for your help! I just set this up on my computer and it's working great! Thanks again!
  19. Soyanonymous macrumors newbie

    Oct 20, 2011
    Use google contacts to eliminate duplicates!

    1)use itunes to Sync all your contacts to GOOGLE CONTACTS

    2)ON GOOGLE CONTACTS, use option FIND DUPLICATES, press MERGE. to eliminate all duplicates.

    3) turn off contact on icloud on your phone.

    4) login to icloud.com and on contact, tab #, select all contacts and delete them.

    5) then sync all your contacts from google contacts, into itunes, into your iphone and finally into icloud!!!
  20. hafr macrumors 68030

    Sep 21, 2011
    People who get duplicates are syncing with two sources. Just deactivate the other one and you're good to go.
  21. Jamooche thread starter macrumors regular

    Jul 23, 2011
    Another interesting issue I found was that about 5-6 contacts had the street address listed 2-3 times. I just deleted the extra addresses and everything was fine. I think that if the information was not initially entered in the correct section boxes (street, town, state, etc.) iCloud / Address Book creates a new address entry with the fields in the correct locations.
  22. eelke macrumors newbie

    Oct 20, 2007
    Also had the problem, and this solution by raulwongroa works great. Thanks :)

  23. Richard L macrumors newbie

    Jul 17, 2010
    Durham, UK
    iCloud and Address Book

    I have had similar problems but also what at first seemed a major catastrophe. It seems that there is no way to overwrite iCloud contacts completely.

    Since IOS 5.0 & 10.7.2 for the first time I had no problems syncing my address book. Everything worked well for my iMac, MacBook, iPad and iPhone. It hadn't since Lion was released and 10.7.2 has been long awaited. All worked well until the other day I changed the backup setting in iTunes for my iPad to tell it to backup to the iMac. Two days ago I noticed that some of my contacts were not duplicated, none were that, but triplicated and quadruplicated. Not all. Further in some the entries were triplicated etc. but not necessarily the same ones where the contacts themselves had been triplicated. I could find no logical reason for this to suddenly happen.

    I knew I had a clean backup from the day before and rather than spend hours putting right all these entries (600 +) deleted the content of address book on my iMac and reinstalled the backup.

    It looked fine but the "look" lasted all of 30 seconds and the whole of the address book emptied itself. I realised that I was still connected to iCloud, it had picked the first cleaning of the address book and decided that it did not want the version I put into the iMac even though it was an Apple archive. I then found it had wiped my MacBook, iPhone and iPad. Gone.

    I tried several times to put it back but it seemed there is a block on you overwriting the data in iCloud's copy of contacts. You can edit, add and delete individual contacts but not do a complete overwrite.

    I tried dropping my archived copy of address book into contacts on iCloud but it rejected it, said it needed a vCal file.

    I then did the following:

    1. Ensured the iMac was not connected or syncing with iCloud. Do that via settings.
    2. Emptied my address book on the iMac.
    3. Restored in the iMac from backup archive.
    4. Then exported the whole of the address book as a vCal file - export in address book gives you the option.
    5. Then reconnected to iCloud and despite address book on the iMac being more recent than iCloud knew, iCloud of course wiped it completely.
    6. I accessed my empty contacts on iCloud itself, dragged and dropped the vCal archive into, all was accepted and everything put right.

    I was fortunate I had a recent backup.

    Something is wrong though or I have missed the "how to" as it seems you cannot overwrite the address book in iCloud from your iMac etc. as you could in MobileMe.

    If therefore you want to tidy up take care, iCloud can wipe everything.:eek:
  24. Jamooche thread starter macrumors regular

    Jul 23, 2011
    I always do a full EXPORT of iCal and Address Book before I try and do anything. It will back each to a single file which you can then re-import if you lose everything.

Share This Page