Duplicate iCal entries in the Cloud

Discussion in 'Apple Music, Apple Pay, iCloud, Apple Services' started by psychedelia, Oct 13, 2011.

  1. psychedelia, Oct 13, 2011
    Last edited: Oct 13, 2011

    psychedelia macrumors regular

    Joined:
    Jan 28, 2009
    #1
    So, basically some how I have buttloads of duplicate entries in the calendar in my iCloud. Now I guess i could go and manually delete all the duplicates, but that would take forever. Because they're duplicated in the cloud, they are also duplicated on my mac. So now, my first solution was to use this iCal dupe deleter and delete them. It does this well on my mac, but a second later the entries are back pushed from iCloud.

    So any advice here? Is there any way to have iCal replace the information in the cloud? Any way to delete the iCal data in the cloud, and then sync the local calender? Any other way?

    Thanks!

    psych


    EDIT:

    I actually managed to solve this myself, and perhaps other people have the same issue so I'll post it.

    Basically i took my local iCal offline, used the duplicate program to delete all the duplicates. Then I exported each of the calenders to separate files (right click each calenders - export). Remember this were all under the iCloud 'banner'. Then i proceeded to delete all of the calenders in iCloud (edit - red stopsign, delete). This of course did the same in local iCal. After this i imported each of the individual calendars to 'On my mac', disabled and re-enabled calendar icloud syncing in system preferences, and voila, the new updated iCal was pushed to the icloud, containing no duplicates.
     
  2. N1ckC macrumors newbie

    Joined:
    Oct 14, 2011
    #2
    I tried this and it did not work. Although there is some info missing from your instructions. When you disable and re-enable iCloud under System Preferences, there is a message that comes up to Merge with iCloud. When I click OK, I get the duplicates back again. Maybe I'm missing a step?
     
  3. wildbunch macrumors newbie

    Joined:
    Oct 14, 2011
    #3
    icloud and iCal duplicated after sync - solution

    Yes i noticed everything had been duplicated on my iCal, not sure if this was because i also had Busycal installed. Simply go to 'calendars' on the top left of iCal, the drop down will appear and untick all the icloud. This will keep a copy on your iCloud but not the duplicate on your iCal.

    On another note, is Busy Cal now defunct that icloud has appeared?
    cheers.
     
  4. N1ckC macrumors newbie

    Joined:
    Oct 14, 2011
    #4
    Well, my response to that is: iHate iCloud, for now.

    Going back to wired syncing...
     
  5. kkthekat macrumors newbie

    Joined:
    Oct 14, 2011
    #5
    It's way easier than all that

    I was having this problem of duplicate entries in iCal, more so on my iPod touch because while I had figured out how to hide the extra entries, they were still showing up in the new notifications bar as upcoming events.

    I was able to solve it by deleting, on my iPod, all of the calendars under "on my mac" and leaving only the iCloud calendars available. This can be done on your computer as well, but I don't think you would need to go to that extreme unless you've got a reason to. All you really need to do is uncheck all the extra copies (they are still there, just not visible) of the calendars (by clicking on Calendars in the upper lefthand corner of iCal). Simple and clean. Only thing left to do is make sure your default calendar is one that is visible.

    I know the initial reaction to change is to be bothered by it, but I really think iCloud works. When I got my iPod touch I was all excited that I could add stuff to my calendar and when I synced it would add to my computer's calendar. Well, it didn't, until iCloud was released. I'm quite happy with iCloud. :)
     
  6. N1ckC macrumors newbie

    Joined:
    Oct 14, 2011
    #6
    Well I'm happy to say I got it figured out. I basically deleted my iCloud account and started over. I think I was getting tripped up on the merge part when I would turn iCal off and back on again in iCloud. I also should have selected to delete the entries when prompted to do so, on my Macbook and iPhone.

    So everything is synced up through iCloud now with no duplicates.

    Yes you could say I was a little frustrated there. Also if you noticed I stated I was unhappy (no wait, I said hated) with iCloud, for now. I wasn't going to quit until I got it figured out.

    I am a recently turned Mac user. I am still trying to get used to the functionality and interface of this system. I am very happy with my Mac and I believe my impatience may come from using PC's up until this point. A co-worker told me that I may feel dumbed down using a Mac, but only because it is much simpler to use and I'm expecting all of the hurdles and errors that come with a PC. I appreciate everyone's response and I hope to be as helpful with tips or advice like everyone else. Thanks again!
     
  7. Sbaugh macrumors newbie

    Joined:
    Oct 16, 2011
    #7
    Can You Elaborate?

    Thanks for letting us know you got this fixed. Would you be able to let me know exactly what process you used? This duplication thing is driving me crazy!!

    Thanks so much for your help!!!
     
  8. psychedelia, Oct 17, 2011
    Last edited: Oct 17, 2011

    psychedelia thread starter macrumors regular

    Joined:
    Jan 28, 2009
    #8
    Yup, sorry for the late reply. But basically, when you re-enable Calender on your mac, at that point the calender info on your iCloud should have been deleted, hence the only thing being merged is your 'new' calenders (just imported). But I guess you figured it out :)
     
  9. samtsham macrumors newbie

    Joined:
    Oct 23, 2011
    #9
    Too too too many calendars!

    Hi all,
    I have the fairly peculiar problem, that I don't only have lots of duplicate calendar entries, I have a ridiculous number of calendars to choose from.

    My current list of calendars to toggle display of in miCal on my iPhone has 20 entries! Some of them are holiday and moon phases calendars I subscribed to, but the others are just mayhem:

    I'm on a German language setting, so some of my calendars have German names, namely Büro (office=Work) and Privat (private, obviously):
    So there's BÜRO, PRIVAT and CALENDAR at: "Local Calendar Default", WORK, BÜRO, PRIVAT, AUSTRIAN HOLIDAYS and LIBRARY LOANS at: "CalDav Calendar Mac". And then there's BÜRO, WORK, WORK (again), PRIVAT, PRIVAT (again), AUSTRIAN HOLIDAYS and LIBRARY LOANS at: "appleID@p0... the rest is cut off, can't read it". I guess, these must be the iCloud calendars, but I really don't know for sure.

    There's also Birthdays (Birthday-calendar, Other), and some moon phases and such. These I could jeopardize, but I don't know what to do with all the others. I'm entirely unsure, how they all got there. Library Loans I know is from Delicious Library.

    I'm using miCal, I used to be on MobileMe, now iCloud.

    Any entry I make on my Mac cannot be edited on the iPhone anymore, it is locked. Entries are all over the place. If I make a new entry on my Mac, I can choose the following calendars: ON MY MAC: Privat, Calendar, Büro. MOBILEME: Privat, Büro, Austrian Holidays, Library Loans, Work. This is surprising, as all MobilMe calendars were transferred over to iCloud, as I understand.

    If I make a new entry on my iPhone, I can choose the following calendars: CALDAV: Work, Büro, Privat, Austrian Holidays and Library Loans. LOCAL CALENDAR DEFAULT: Privat, Büro, Calendar.

    I have no idea, what gets synched and why, I don't now where I got the CalDav calendars and why I need them, I don't know why I cannot edit calendar entries on my iPhone, and I don't know HOW TO DELETE ALL THE SUPERFLOUS CALENDARS. I can deactivate them, but how do I get rid of them?

    Can anyone help me, please? I'm seriously stuck here.

    Regards, and all the best ...

    SAM :confused:
     
  10. metoo6000 macrumors regular

    Joined:
    Sep 18, 2007
    Location:
    London, UK
    #10
    This issue got to be fixed by Apple rather than users. I know iCloud is only v1.0, so I would expect this issue is resolved in the next version. Until then, I would stick with traditional sync with iTunes. :(
     

Share This Page