duplicated server connections, afp vs smb?

Discussion in 'Mac OS X Server, Xserve, and Networking' started by decksnap, Nov 5, 2015.

  1. decksnap macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #1
    We have various mac systems connected to a mac server running Snow Leopard. The systems range from snow leopard to Yosemite. At least on our Yosemite systems, we are seeing the server mounted twice on our desktops. One appears to be afp and the other smb. I basically have two questions - which should we be connecting to, and how do we hide or disable the incorrect one?

    Screen Shot 2015-11-05 at 10.15.58 AM.png server-info.jpg
     
  2. hobowankenobi macrumors regular

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #2
    Usually this is a symptom of both protocols being on, supported and requested. Pros and Cons...as to which you should use. AFP is the old stand by, but often SMB is used on Windows and NAS file servers. On a Mac server....usually SMB is on so Win work stations can connect too.

    The bigger question is, why are both mounting? Usually one uses one, or the other at a time. Do they mount automatically? There are several ways this can be automated.....like a user log-in item (listed on the Sys Pref Pane/User for each account). Could be Profile of the machines are managed. Could also be a custom login script...etc.

    Hard to say, without investigating, but it sounds as though the machines were setup that way.
     
  3. hobowankenobi macrumors regular

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #3
    If you only have Macs connecting to the Mac server, you could simply turn SMB sharing off. Just be sure it is not required my a non-Mac user. Once off, you won't see the SMB stare on the network anymore.

    Same is true if you wanted to go SMB only; you can turn AFP off instead.
     
  4. decksnap thread starter macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #4
    Thanks. We have 2 PCs attached for quickbooks duties - not sure it matters. So then the next question is, is one better to connect with than the other, speed or otherwise? I can't seem to 'disconnect' one or the other once I'm connected to the server. They won't eject. I seem to always be connected to both.
     
  5. decksnap thread starter macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #5
    Sorry I actually missed your first post and only read the second one. I set up all these systems personally... basically at some point during setup I punch in the server IP address in the connect to server box. That's the only setup done. Everyone gets a username and password on the server, but we aren't using any services. Basically I know enough to be dangerous and not much more! I think things have changed with newer OS versions where Apple is moving to SMB, but we have snow leopard users as well as Yosemite users, and the two PCs.
     
  6. hobowankenobi, Nov 5, 2015
    Last edited: Nov 6, 2015

    hobowankenobi macrumors regular

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #6
    OK, so you need both. The PCs can only connect (normally) via SMB. The Macs....can do either.

    AFP is a bit faster on the Mac side.

    It sounds like the Macs are set up (perhaps inadvertently) to connect with both protocols. Take one that does this, and check the User preference pane Log-in items. If you see anything there about connecting to the server (the IP or name of server), you can remove it.

    Once all server log ins are removed, log out and log in. If that is all that was set up, the server would NOT mount.
     
  7. hobowankenobi macrumors regular

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #7
    Once that is done, from the desktop, you can manually connect to the server, carefully choosing AFP or SMB. You can do it via the File/Connect to Server menu, or, you can use the network Bonjour browser in the Finder (with the Mac or PC icons).

    Connect, verify it is what you want.

    Last, you can reset the auto connection back in the User Pref pane, using the plus button to add the correct server connection back. Here's a quick overview.
     
  8. decksnap thread starter macrumors 68040

    decksnap

    Joined:
    Apr 11, 2003
    #8
    Very helpful I appreciate all the explanation! I'll give it a go and see what happens. Thanks again.
     
  9. nopster macrumors newbie

    Joined:
    Jun 10, 2009
    #9
    Hi, did you resolve the problem? I have the same issue between mac client el capitan and mac server with os x el capitan server release. I wrote also on apple discussions here, but didn't find a solution, even checked what's written in this thread.
    No automatic login on startup. If I disable SMB sharing connection on os x server, on mac client I cannot see sharing folders on that server.
    Any kind of help is really appreciated.
     

Share This Page